fix compile of iptunnel4 for the 2.4 kernel
authorthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Jan 2009 00:18:06 +0000 (00:18 +0000)
committerthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Jan 2009 00:18:06 +0000 (00:18 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14081 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/netsupport.mk

index 70e239c412646f7a6eb2f5f8cf829571bbdeaacf..d207003f8b4f177e6559a3d673a63983a5c743ec 100644 (file)
@@ -216,19 +216,22 @@ endef
 
 $(eval $(call KernelPackage,ipsec6))
 
-
-# NOTE: tunnel4 is not selectable by itself, so enable ipip for that
 define KernelPackage/iptunnel4
-  SUBMENU:=$(NETWORK_SUPPORT_MENU)
-  TITLE:=IPv4 tunneling
-  DEPENDS:= @LINUX_2_6
-  KCONFIG:= \
-       CONFIG_NET_IPIP \
-       CONFIG_INET_TUNNEL
-  FILES:= $(foreach mod,tunnel4, \
-       $(LINUX_DIR)/net/ipv4/$(mod).$(LINUX_KMOD_SUFFIX) \
-  )
-  AUTOLOAD:=$(call AutoLoad,31,tunnel4)
+  TITLE:=IP in IP encapsulation support
+  KCONFIG:=$(CONFIG_NET_IPIP)
+  SUBMENU:=$(NSMENU)
+endef
+
+define KernelPackage/iptunnel4/2.4
+  FILES:=$(LINUX_DIR)/net/ipv4/ipip.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,ipip)
+endef
+
+define KernelPackage/iptunnel4/2.6
+  FILES:= \
+       $(LINUX_DIR)/net/ipv4/ipip.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/net/ipv4/tunnel4.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,30,ipip tunnel4)
 endef
 
 define KernelPackage/iptunnel4/description
@@ -237,7 +240,6 @@ endef
 
 $(eval $(call KernelPackage,iptunnel4))
 
-
 define KernelPackage/iptunnel6
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=IPv6 tunneling