[backfire] backport r24631, needed for at least gstreamer on backfire
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 10 Jul 2011 19:55:45 +0000 (19:55 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 10 Jul 2011 19:55:45 +0000 (19:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@27579 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/flex/Makefile [new file with mode: 0644]

index 5bf28a5f5ee9ef61640f7e91512dc92f0810c38f..8cb50648df1191a15c5ae134a7efd64605446cb1 100644 (file)
@@ -13,7 +13,7 @@ tools-y :=
 ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
 tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
 endif
-tools-y += m4 libtool autoconf automake bison pkg-config sed mklibs
+tools-y += m4 libtool autoconf automake flex bison pkg-config sed mklibs
 tools-y += sstrip ipkg-utils genext2fs libuuid mtd-utils mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2 xz cmake
 tools-y += mm-macros xorg-macros xfce-macros missing-macros
@@ -35,6 +35,7 @@ ifdef CONFIG_GCC_USE_GRAPHITE
 endif
 
 # builddir dependencies
+$(curdir)/bison/compile := $(curdir)/flex/install
 $(curdir)/pkg-config/compile := $(curdir)/sed/install
 $(curdir)/libtool/compile := $(curdir)/sed/install
 $(curdir)/squashfs/compile := $(curdir)/lzma-old/install
diff --git a/tools/flex/Makefile b/tools/flex/Makefile
new file mode 100644 (file)
index 0000000..9d4ae13
--- /dev/null
@@ -0,0 +1,32 @@
+# 
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=flex
+PKG_VERSION:=2.5.35
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_URL:=@SF/$(PKG_NAME)
+PKG_MD5SUM:=10714e50cea54dc7a227e3eddcd44d57
+PKG_CAT:=bzcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR)
+endef
+
+define Host/Install
+       $(MAKE) -C $(HOST_BUILD_DIR) install
+endef
+
+define Host/Clean
+       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))