don't replace powerpc arch with ppc
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 23 Oct 2007 06:23:12 +0000 (06:23 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 23 Oct 2007 06:23:12 +0000 (06:23 +0000)
'powerpc' is a valid arch for the LINUX_KARCH variable, but the build
system unconditionally replaces LIUNUX_KARCH=powerpc with
LINUX_KARCH=ppc.

This change only does the replacement if LINUX_KARCH isn't set. This
allows us to use the powerpc architecture.

Signed-off-by: Jeremy Kerr <jk@ozlabs.org>
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@9405 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel.mk
target/linux/amcc/Makefile
target/linux/magicbox/Makefile

index 748605705289425a6363d8855557476845253b4c..f9baeef0ac3daa5505344310b9656c49c960931a 100644 (file)
@@ -51,13 +51,14 @@ endif
 ifneq (,$(findstring uml,$(BOARD)))
   LINUX_KARCH:=um
 else
-  LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
-       -e 's/mipsel/mips/' \
-       -e 's/mipseb/mips/' \
-       -e 's/powerpc/ppc/' \
-       -e 's/sh[234]/sh/' \
-       -e 's/armeb/arm/' \
-  )
+  ifeq (,$(LINUX_KARCH))
+    LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
+         -e 's/mipsel/mips/' \
+         -e 's/mipseb/mips/' \
+         -e 's/sh[234]/sh/' \
+         -e 's/armeb/arm/' \
+    )
+  endif
 endif
 
 
index d582d8191531f6b24d956e7eb1b49f4863558263..5e52d38c77aa1ef2e8e8a6853ce95590863a4615 100644 (file)
@@ -12,6 +12,7 @@ BOARDNAME:=AMCC Taishan
 FEATURES:=jffs2
 
 LINUX_VERSION:=2.6.21.5
+LINUX_KARCH:=ppc
 
 include $(INCLUDE_DIR)/target.mk
 
index b13009562439d7491ba40f68e72d041205e27b60..15f035a82e25c0a846ed801b1a799d2390cee102 100644 (file)
@@ -12,6 +12,7 @@ BOARDNAME:=Magicbox
 FEATURES:=squashfs jffs2
 
 LINUX_VERSION:=2.6.22.4
+LINUX_KARCH:=ppc
 
 include $(INCLUDE_DIR)/target.mk