[backfire] merge automake Makefile from trunk
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 1 Feb 2012 15:17:02 +0000 (15:17 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 1 Feb 2012 15:17:02 +0000 (15:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@29980 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/automake/Makefile

index 70103d5a95a31da555b5a74cf2094d7cfa2afff3..c30a9900e613e5f527ff29f250b1c5c7b67c5faf 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,15 +15,8 @@ PKG_MD5SUM:=c2972c4d9b3e29c03d5f2af86249876f
 
 include $(INCLUDE_DIR)/host-build.mk
 
-define Host/Configure
-       $(call Host/Configure/Default,\
-               --datarootdir=$(STAGING_DIR_HOST)/share \
-       )
-endef
-
-define Host/Compile
-       $(MAKE) -C $(HOST_BUILD_DIR)
-endef
+HOST_CONFIGURE_ARGS += --datarootdir=$(STAGING_DIR_HOST)/share
+HOST_CONFIGURE_VARS += am_cv_prog_PERL_ithreads=no
 
 define Host/Install
        $(MAKE) -C $(HOST_BUILD_DIR) install