[ifxmips] meta partition should not span brn-boot sector
authorblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Mar 2010 15:53:48 +0000 (15:53 +0000)
committerblogic <blogic@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 24 Mar 2010 15:53:48 +0000 (15:53 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20401 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ifxmips/patches-2.6.30/140-mtd.patch

index 294d97335e6d4e935661e80ea5748c2bc4e16949..184c78ca98f9c53178bcc5db6ede8a8047ec8c75 100644 (file)
@@ -1,7 +1,7 @@
 Index: linux-2.6.30.10/drivers/mtd/maps/Makefile
 ===================================================================
---- linux-2.6.30.10.orig/drivers/mtd/maps/Makefile     2010-03-18 14:27:04.000000000 +0100
-+++ linux-2.6.30.10/drivers/mtd/maps/Makefile  2010-03-18 14:27:07.000000000 +0100
+--- linux-2.6.30.10.orig/drivers/mtd/maps/Makefile     2009-12-04 07:00:07.000000000 +0100
++++ linux-2.6.30.10/drivers/mtd/maps/Makefile  2010-03-24 15:32:04.000000000 +0100
 @@ -62,3 +62,4 @@
  obj-$(CONFIG_MTD_BFIN_ASYNC)  += bfin-async-flash.o
  obj-$(CONFIG_MTD_RBTX4939)    += rbtx4939-flash.o
@@ -10,8 +10,8 @@ Index: linux-2.6.30.10/drivers/mtd/maps/Makefile
 Index: linux-2.6.30.10/drivers/mtd/maps/ifxmips.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-2.6.30.10/drivers/mtd/maps/ifxmips.c 2010-03-18 14:27:17.000000000 +0100
-@@ -0,0 +1,281 @@
++++ linux-2.6.30.10/drivers/mtd/maps/ifxmips.c 2010-03-24 16:46:26.000000000 +0100
+@@ -0,0 +1,282 @@
 +/*
 + * This program is free software; you can redistribute it and/or modify
 + * it under the terms of the GNU General Public License as published by
@@ -253,6 +253,7 @@ Index: linux-2.6.30.10/drivers/mtd/maps/ifxmips.c
 +                      parts[3].size -= ifxmips_mtd->erasesize;
 +                      parts[4].offset = ifxmips_mtd->size - ifxmips_mtd->erasesize;
 +                      parts[4].size = ifxmips_mtd->erasesize;
++                      ifxmips_meta_partition.size -= ifxmips_mtd->erasesize;
 +              } else {
 +                      num_parts--;
 +              }