backfire: package/base-files: add get_magic_long() to common upgrade script (backport...
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Mar 2011 14:53:57 +0000 (14:53 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Mar 2011 14:53:57 +0000 (14:53 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@26115 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/lib/upgrade/common.sh

index 390327a9e181fa9a57ef25b73af81fc5977339eb..d58e17df62ebcecb963d4188168d6075ac7006ce 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=43.12
+PKG_RELEASE:=43.14
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index 970016e7baac276d3eb595370bc0336941d697a2..bf9c40d295dbfc068f50b521ee796db1954e5389 100644 (file)
@@ -130,6 +130,10 @@ get_magic_word() {
        get_image "$@" | dd bs=2 count=1 2>/dev/null | hexdump -v -n 2 -e '1/1 "%02x"'
 }
 
+get_magic_long() {
+       get_image "$@" | dd bs=4 count=1 2>/dev/null | hexdump -v -n 4 -e '1/1 "%02x"'
+}
+
 refresh_mtd_partitions() {
        mtd refresh rootfs
 }