[tools] add tool for squashfs4 image generation (w/o LZMA support)
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 15 May 2009 12:07:21 +0000 (12:07 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 15 May 2009 12:07:21 +0000 (12:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@15864 3c298f89-4303-0410-b956-a3cf2f4a3e73

tools/Makefile
tools/squashfs4/Makefile [new file with mode: 0644]

index 19ee453343b0a7fcbfc9c8018439160853ec41a3..ebcbad4e7836f5c19f46761807cd9407c8a43838 100644 (file)
@@ -1,4 +1,4 @@
-# 
+#
 # Copyright (C) 2007 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
@@ -12,7 +12,7 @@ curdir:=tools
 tools-y :=
 tools-$(CONFIG_GCC_VERSION_4_3)$(CONFIG_GCC_VERSION_4_4) += gmp mpfr
 tools-y += m4 autoconf automake bison pkg-config sed
-tools-y += sstrip ipkg-utils genext2fs squashfs mtd-utils lzma-old mkimage
+tools-y += sstrip ipkg-utils genext2fs squashfs squashfs4 mtd-utils lzma-old mkimage
 tools-y += firmware-utils patch-cmdline quilt yaffs2
 
 tools-$(CONFIG_CCACHE) += ccache
diff --git a/tools/squashfs4/Makefile b/tools/squashfs4/Makefile
new file mode 100644 (file)
index 0000000..f172d3b
--- /dev/null
@@ -0,0 +1,36 @@
+#
+# Copyright (C) 2009 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=squashfs4
+PKG_VERSION:=4.0
+
+PKG_SOURCE:=squashfs$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@SF/squashfs
+PKG_MD5SUM:=a3c23391da4ebab0ac4a75021ddabf96
+PKG_CAT:=zcat
+
+HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/squashfs$(PKG_VERSION)
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR)/squashfs-tools \
+               mksquashfs unsquashfs
+endef
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/mksquashfs $(STAGING_DIR_HOST)/bin/mksquashfs4
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/squashfs-tools/unsquashfs $(STAGING_DIR_HOST)/bin/unsquashfs4
+endef
+
+define Host/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/mksquashfs4
+       rm -f $(STAGING_DIR_HOST)/bin/unsquashfs4
+endef
+
+$(eval $(call HostBuild))