fix kernel postinst scripts
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 30 Jul 2006 17:06:02 +0000 (17:06 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 30 Jul 2006 17:06:02 +0000 (17:06 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4336 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/Makefile

index b1155f4286672e164f259d5c7a5599ad8c5f1611..e5094ef01142360af222717947330a08963f97df 100644 (file)
@@ -45,8 +45,8 @@ define ModuleAutoLoad
        $(3) \
        if [ -n "$$$$$$$$modules" ]; then \
                mkdir -p $(2)/etc/modules.d; \
-               echo "#!/bin/sh" >> $(2)/CONTROL/postinst; \
-               echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit" >> $(2)/CONTROL/postinst; \
+               echo "#!/bin/sh" > $(2)/CONTROL/postinst; \
+               echo "[ -z \"\$$$$$$$$IPKG_INSTROOT\" ] || exit 0" >> $(2)/CONTROL/postinst; \
                echo ". /etc/functions.sh" >> $(2)/CONTROL/postinst; \
                echo "load_modules $$$$$$$$modules" >> $(2)/CONTROL/postinst; \
                chmod 0755 $(2)/CONTROL/postinst; \