[backfire] merge r28254
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Sep 2011 22:32:15 +0000 (22:32 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 18 Sep 2011 22:32:15 +0000 (22:32 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@28255 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uhttpd/Makefile
package/uhttpd/src/uhttpd-cgi.c

index ca537a4c1ca05b3eade343c85c37f6eaca3607a0..a43b1014f8c9d10cbc6e4d0a3a8b346073857c54 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=23.2
+PKG_RELEASE:=23.3
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 PKG_BUILD_DEPENDS := libcyassl liblua
index ed688514c40e0c026591f4beb712c481e3e84698..2f94fe26f58f65f66e1d223b18642b30ae9d37bd 100644 (file)
@@ -1,7 +1,7 @@
 /*
  * uhttpd - Tiny single-threaded httpd - CGI handler
  *
- *   Copyright (C) 2010 Jo-Philipp Wich <xm@subsignal.org>
+ *   Copyright (C) 2010-2011 Jo-Philipp Wich <xm@subsignal.org>
  *
  *  Licensed under the Apache License, Version 2.0 (the "License");
  *  you may not use this file except in compliance with the License.
@@ -42,7 +42,7 @@ static struct http_response * uh_cgi_header_parse(char *buf, int len, int *off)
 
                bufptr = &buf[0];
 
-               for( pos = 0; pos < len; pos++ )
+               for( pos = 0; pos < off; pos++ )
                {
                        if( !hdrname && (buf[pos] == ':') )
                        {
@@ -60,11 +60,11 @@ static struct http_response * uh_cgi_header_parse(char *buf, int len, int *off)
 
                        else if( (buf[pos] == '\r') || (buf[pos] == '\n') )
                        {
-                               buf[pos++] = 0;
-
                                if( ! hdrname )
                                        break;
 
+                               buf[pos++] = 0;
+
                                if( (pos < len) && (buf[pos] == '\n') )
                                        pos++;