add kmod-oprofile to package/kernel (backport of r25690)
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Feb 2011 01:13:09 +0000 (01:13 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 24 Feb 2011 01:13:09 +0000 (01:13 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@25691 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk

index ffcb48ffd2aaf5213337bda96683bf3ec9f2ff9e..53895bd8d53355257d1fe6a49a2170ca0335212b 100644 (file)
@@ -872,6 +872,21 @@ endef
 $(eval $(call KernelPackage,textsearch))
 
 
+define KernelPackage/oprofile
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=OProfile profiling support
+  KCONFIG:=CONFIG_OPROFILE
+  FILES:=$(LINUX_DIR)/arch/$(LINUX_KARCH)/oprofile/oprofile.$(LINUX_KMOD_SUFFIX)
+  DEPENDS:=@KERNEL_PROFILING @!LINUX_2_4
+endef
+
+define KernelPackage/oprofile/description
+  Kernel module for support for oprofile system profiling.
+endef
+
+$(eval $(call KernelPackage,oprofile))
+
+
 define KernelPackage/rfkill
   SUBMENU:=$(OTHER_MENU)
   TITLE:=RF switch subsystem support