ar71xx: sync profile/target default changes with trunk
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Sep 2011 19:12:12 +0000 (19:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Sep 2011 19:12:12 +0000 (19:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@28174 3c298f89-4303-0410-b956-a3cf2f4a3e73

13 files changed:
target/linux/ar71xx/Makefile
target/linux/ar71xx/profiles/00-default.mk
target/linux/ar71xx/profiles/01-minimal.mk
target/linux/ar71xx/profiles/02-madwifi.mk
target/linux/ar71xx/profiles/atheros.mk
target/linux/ar71xx/profiles/atlantis.mk
target/linux/ar71xx/profiles/buffalo.mk
target/linux/ar71xx/profiles/d-link.mk
target/linux/ar71xx/profiles/linksys.mk
target/linux/ar71xx/profiles/netgear.mk
target/linux/ar71xx/profiles/planex.mk
target/linux/ar71xx/profiles/tp-link.mk
target/linux/ar71xx/profiles/trendnet.mk

index 5e33c10d97b2b7c2d5b0368fadfdd317bd43ed92..01af9afc15b5fd860c8430681e3f805d7a744bdb 100644 (file)
@@ -18,7 +18,8 @@ include $(INCLUDE_DIR)/target.mk
 
 DEFAULT_PACKAGES += \
        kmod-leds-gpio kmod-input-core kmod-input-polldev \
-       kmod-input-gpio-buttons kmod-button-hotplug swconfig
+       kmod-input-gpio-buttons kmod-button-hotplug swconfig \
+       kmod-ath9k wpad-mini
 
 define Target/Description
        Build firmware images for Atheros AR71xx/AR913x based boards.
index aa46f22c54a7a0105c0ffbace0b5f4222d3847a6..1aff94e8756a6a7c66a1f9b07e3bd0c63a6599d9 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Default
        NAME:=Default Profile (all drivers)
-       PACKAGES:=kmod-ath9k kmod-madwifi kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig vsc7385-ucode-ap83 vsc7385-ucode-pb44 vsc7395-ucode-ap83 vsc7395-ucode-pb44 wpad-mini
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 swconfig
 endef
 
 define Profile/Default/Description
index 3651c88ab2d49356e4c29d077ebc862be8ee9e16..f3ecda5e245a902a2ad96a4f2a68ffa3a4b5614c 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/DefaultNoWifi
        NAME:=Default Profile (no WiFi)
-       PACKAGES:=
+       PACKAGES:=-kmod-ath9k -wpad-mini
 endef
 
 define Profile/DefaultNoWifi/Description
index 7c22c53db574684e8ce507bfa68d655df1ac2ba7..5e8831d9778f8ece301c7b8a91626c74d771a70c 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/Madwifi
        NAME:=Atheros WiFi (madwifi)
-       PACKAGES:=kmod-madwifi wpad-mini
+       PACKAGES:=kmod-madwifi -kmod-ath9k
 endef
 
 define Profile/Madwifi/Description
index a7ed71414fea30ae6c51cbf0c5d7f3c1384e43f3..b7050f78262b268fa1a35a3b28e0d4573ef5a5fb 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/AP81
        NAME:=Atheros AP81 reference board
-       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2
 endef
 
 define Profile/AP81/Description
@@ -18,7 +18,7 @@ $(eval $(call Profile,AP81))
 
 define Profile/AP83
        NAME:=Atheros AP83 reference board
-       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb2 \
+       PACKAGES:=kmod-usb-core kmod-usb2 \
                  vsc7385-ucode-ap83 vsc7395-ucode-ap83
 endef
 
@@ -30,7 +30,7 @@ $(eval $(call Profile,AP83))
 
 define Profile/PB42
        NAME:=Atheros PB42 reference board
-       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
 endef
 
 define Profile/PB42/Description
@@ -41,7 +41,7 @@ $(eval $(call Profile,PB42))
 
 define Profile/PB44
        NAME:=Atheros PB44 reference board
-       PACKAGES:=wpad-mini kmod-ath9k kmod-usb-core kmod-usb-ohci kmod-usb2 \
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2 \
                  vsc7385-ucode-pb44 vsc7395-ucode-pb44
 endef
 
index c63fd9c275c61069fb0c881e2bb2a246c7807af5..073d8d1f8bcd1c9a1040c36c5c2934846827ae9e 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/A02RBW300N
        NAME:=Atlantis-Land A02-RB-W300N
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/A02RBW300N/Description
index ffaa0c58dc21e4592049d19914a9605b5435b3c6..4a8facce520705016451e4ee522575f0cc9d19c0 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/WZRHPG300NH
        NAME:=Buffalo WZR-HP-G300NH
-       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2
 endef
 
 define Profile/WZRHPG300NH/Description
index bf99e099a988b260ff1ab16ed5ecf034ff9e4c41..594cfde4fe4213a9900a30d06f4e260da0d091d7 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/DIR600A1
        NAME:=D-Link DIR-600 rev. A1
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/DIR600A1/Description
@@ -19,7 +19,7 @@ $(eval $(call Profile,DIR600A1))
 
 define Profile/DIR615C1
        NAME:=D-Link DIR-615 rev. C1
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/DIR615C1/Description
@@ -31,7 +31,7 @@ $(eval $(call Profile,DIR615C1))
 
 define Profile/DIR825B1
        NAME:=D-Link DIR-825 rev. B1
-       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2
 endef
 
 define Profile/DIR825B1/Description
index f3253e728f4e0120378a9026d908ff6fbef5641a..5b5e3b213c650e032c54cda0b99e1263e4ad7bee 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/WRT160NL
        NAME:=Linksys WRT160NL
-       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2 swconfig
+       PACKAGES:=kmod-usb-core kmod-usb2 swconfig
 endef
 
 define Profile/WRT160NL/Description
@@ -16,7 +16,7 @@ endef
 
 define Profile/WRT400N
        NAME:=Linksys WRT400N
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/WRT400N/Description
index 6a65e7d6487aa6d6c46c1e1a4685bb0aef28f11d..fcb960af82ba975a7cb68bf4cf89eee93cb491b3 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/WNDR3700
        NAME:=NETGEAR WNDR3700
-       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb-ohci kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb-ohci kmod-usb2
 endef
 
 define Profile/WNDR3700/Description
index 63e539c4e42bf25d1fd12d9cd67a41199ef25916..6e161568af1bad514e135ad694c8b757acda46c4 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/MZKW04NU
        NAME:=Planex MZK-W04NU
-       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2
 endef
 
 define Profile/MZKW04NU/Description
@@ -18,7 +18,7 @@ $(eval $(call Profile,MZKW04NU))
 
 define Profile/MZKW300NH
        NAME:=Planex MZK-W300NH
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/MZKW300NH/Description
index ba08ee410b31fca1130f164330c2cb7253599cc7..aab7fbcf7e23b8fc1776317bfd9ae8d3a222b293 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/TLWR741NDV1
        NAME:=TP-LINK TL-WR741ND v1
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR741NDV1/Description
@@ -19,7 +19,7 @@ $(eval $(call Profile,TLWR741NDV1))
 
 define Profile/TLWR740NV1
     NAME:=TP-LINK TL-WR740N v1
-    PACKAGES:=kmod-ath9k wpad-mini
+    PACKAGES:=
 endef
 
 define Profile/TLWR740NV1/Description
@@ -30,7 +30,7 @@ $(eval $(call Profile,TLWR740NV1))
 
 define Profile/TLWR841NV15
        NAME:=TP-LINK TL-WR841N v1.5
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NV15/Description
@@ -41,7 +41,7 @@ $(eval $(call Profile,TLWR841NV15))
 
 define Profile/TLWR841NDV3
        NAME:=TP-LINK TL-WR841ND v3
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NDV3/Description
@@ -52,7 +52,7 @@ $(eval $(call Profile,TLWR841NDV3))
 
 define Profile/TLWR841NDV5
        NAME:=TP-LINK TL-WR841ND v5
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR841NDV5/Description
@@ -63,7 +63,7 @@ $(eval $(call Profile,TLWR841NDV5))
 
 define Profile/TLWR941NDV2
        NAME:=TP-LINK TL-WR941ND v2
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV2/Description
@@ -74,7 +74,7 @@ $(eval $(call Profile,TLWR941NDV2))
 
 define Profile/TLWR941NDV3
        NAME:=TP-LINK TL-WR941ND v3
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV3/Description
@@ -85,7 +85,7 @@ $(eval $(call Profile,TLWR941NDV3))
 
 define Profile/TLWR941NDV4
        NAME:=TP-LINK TL-WR941ND v4
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TLWR941NDV4/Description
@@ -96,7 +96,7 @@ $(eval $(call Profile,TLWR941NDV4))
 
 define Profile/TLWR1043NDV1
        NAME:=TP-LINK TL-WR1043ND v1
-       PACKAGES:=kmod-ath9k wpad-mini kmod-usb-core kmod-usb2
+       PACKAGES:=kmod-usb-core kmod-usb2
 endef
 
 define Profile/TLWR1043NDV1/Description
index 20a08f3842e1f8dcc3e1b848d82cb638d99e3f83..de8f6695b7cdc21469fc8cbabdefb08ab82979ef 100644 (file)
@@ -7,7 +7,7 @@
 
 define Profile/TEW632BRP
        NAME:=TRENDNet TEW-632BRP
-       PACKAGES:=kmod-ath9k wpad-mini
+       PACKAGES:=
 endef
 
 define Profile/TEW632BRP/Description
@@ -18,7 +18,7 @@ $(eval $(call Profile,TEW632BRP))
 
 define Profile/TEW652BRP
        NAME:=TRENDNet TEW-652BRP
-       PACKAGES:=kmod-ath9k
+       PACKAGES:=
 endef
 
 define Profile/TEW652BRP/Description