fix stampfiles for host-builds
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Feb 2007 21:01:21 +0000 (21:01 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Feb 2007 21:01:21 +0000 (21:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6367 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk

index 1511242f95b5074f01ca9105461bff9b3ab6d300..ea7cd3acafd55782b092f5731b601936c43e3c93 100644 (file)
@@ -98,6 +98,7 @@ define HostBuild
 
   $(STAGING_DIR)/stampfiles/.host_$(PKG_NAME)-installed: $(PKG_BUILD_DIR)/.built
        $(call Build/Install)
+       mkdir -p $$(shell dirname $$@)
        touch $$@
        
   ifdef Build/Install