[package] iptables: add comment match to the core package
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Dec 2009 20:52:58 +0000 (20:52 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 8 Dec 2009 20:52:58 +0000 (20:52 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18706 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/netfilter.mk
package/iptables/Makefile

index b08d521f6fd9e0eec535dbc89a5656c96313f1d7..9eeee4f6e1c26eac31a436397de0581402cf4bbd 100644 (file)
@@ -65,7 +65,7 @@ $(eval $(call nf_add,EBTABLES_WATCHERS,CONFIG_BRIDGE_EBT_ULOG, $(P_EBT)ebt_ulog)
 $(eval $(call nf_add,EBTABLES_WATCHERS,CONFIG_BRIDGE_EBT_NFLOG, $(P_EBT)ebt_nflog))
 
 # userland only
-$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_CORE,CONFIG_IP_NF_IPTABLES, xt_standard ipt_icmp xt_tcp xt_udp)))
+$(eval $(if $(NF_KMOD),,$(call nf_add,IPT_CORE,CONFIG_IP_NF_IPTABLES, xt_standard ipt_icmp xt_tcp xt_udp xt_comment)))
 
 $(eval $(call nf_add,IPT_CORE,CONFIG_IP_NF_MATCH_LIMIT, $(P_V4)ipt_limit))
 $(eval $(call nf_add,IPT_CORE,CONFIG_NETFILTER_XT_MATCH_LIMIT, $(P_XT)xt_limit))
index f4d59abd91b8d498f7523666a0238834e0117834..747cba3ecdacca25101ea1865a56cb12b21edc37 100644 (file)
@@ -52,6 +52,7 @@ endef
 define Package/iptables/description
  IPv4 firewall administration tool.
  Includes support for:
+ - comment
  - limit
  - LOG
  - mac