the redboot parsing function needs to be exported
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Apr 2007 09:47:27 +0000 (09:47 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 1 Apr 2007 09:47:27 +0000 (09:47 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6778 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/rdc-2.6/patches/001-rdc3210_flash_map.patch

index b3a4adb00db6f51d02d4d3bf51794df30847004b..7411f06816d506365442e456b96f8e97a71dff28 100644 (file)
@@ -25,3 +25,15 @@ diff -urN linux-2.6.17/drivers/mtd/maps/Makefile linux-2.6.17.new/drivers/mtd/ma
  obj-$(CONFIG_MTD_RPXLITE)     += rpxlite.o
  obj-$(CONFIG_MTD_TQM8XXL)     += tqm8xxl.o
  obj-$(CONFIG_MTD_SA1100)      += sa1100-flash.o
+diff -urN linux-2.6.19/drivers/mtd/redboot.c linux-2.6.19.new/drivers/mtd/redboot.c
+--- linux-2.6.19/drivers/mtd/redboot.c  2006-12-18 17:09:14.000000000 +0100
++++ linux-2.6.19.new/drivers/mtd/redboot.c      2006-12-18 17:14:26.000000000 +0100
+@@ -39,7 +39,7 @@
+        return 1;
+ }
+
+-static int parse_redboot_partitions(struct mtd_info *master,
++int parse_redboot_partitions(struct mtd_info *master,
+                              struct mtd_partition **pparts,
+                              unsigned long fis_origin)
+ {