[backfire] merge r27666
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jul 2011 22:21:18 +0000 (22:21 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Jul 2011 22:21:18 +0000 (22:21 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@27667 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/lua/Makefile
package/resolveip/Makefile [new file with mode: 0644]
package/resolveip/src/resolveip.c [new file with mode: 0644]

index fdbbddc4015502ce169350804fa437f8609d4d03..55329cd3c77c44901a401c2bb707345b364590f9 100644 (file)
@@ -86,7 +86,7 @@ endef
 define Build/Configure
 endef
 
-TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC) -std=gnu99
+TARGET_CFLAGS += -DLUA_USE_LINUX $(FPIC) -std=gnu99 -ggdb3
 
 ifneq ($(CONFIG_USE_EGLIBC),)
   ifeq ($(CONFIG_EGLIBC_OPTION_EGLIBC_UTMP),)
diff --git a/package/resolveip/Makefile b/package/resolveip/Makefile
new file mode 100644 (file)
index 0000000..6ab04e1
--- /dev/null
@@ -0,0 +1,44 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=resolveip
+PKG_RELEASE:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/resolveip
+  SECTION:=utils
+  CATEGORY:=Base system
+  TITLE:=Simple DNS resolver with configurable timeout
+endef
+
+define Package/resolveip/description
+ This package contains the small resolveip utility which
+ can be used by scripts to turn host names into numeric
+ IP addresses. It supports IPv4 and IPv6 resolving and
+ has a configurable timeout to guarantee a certain maximum
+ runtime in case of slow or defunct DNS servers.
+endef
+
+define Build/Prepare
+       $(INSTALL_DIR) $(PKG_BUILD_DIR)
+       $(INSTALL_DATA) ./src/resolveip.c $(PKG_BUILD_DIR)/
+endef
+
+define Build/Compile
+       $(TARGET_CC) $(TARGET_CFLAGS) -Wall \
+               -o $(PKG_BUILD_DIR)/resolveip $(PKG_BUILD_DIR)/resolveip.c
+endef
+
+define Package/resolveip/install
+       $(INSTALL_DIR) $(1)/usr/bin
+       $(INSTALL_BIN) $(PKG_BUILD_DIR)/resolveip $(1)/usr/bin/
+endef
+
+$(eval $(call BuildPackage,resolveip))
diff --git a/package/resolveip/src/resolveip.c b/package/resolveip/src/resolveip.c
new file mode 100644 (file)
index 0000000..8d6788c
--- /dev/null
@@ -0,0 +1,98 @@
+/*
+ * Based on code found at https://dev.openwrt.org/ticket/4876 .
+ * Extended by Jo-Philipp Wich <jow@openwrt.org> for use in OpenWrt.
+ *
+ * You may use this program under the terms of the GPLv2 license.
+ */
+
+#include <string.h>
+#include <stdio.h>
+#include <sys/types.h>
+#include <sys/socket.h>
+#include <netdb.h>
+#include <arpa/inet.h>
+#include <netinet/in.h>
+#include <stdlib.h>
+#include <unistd.h>
+#include <signal.h>
+
+
+static void abort_query(int sig)
+{
+       exit(1);
+}
+
+static void show_usage(void)
+{
+       printf("Usage:\n");
+       printf("        resolveip -h\n");
+       printf("        resolveip [-t timeout] hostname\n");
+       printf("        resolveip -4 [-t timeout] hostname\n");
+       printf("        resolveip -6 [-t timeout] hostname\n");
+       exit(255);
+}
+
+int main(int argc, char **argv)
+{
+       int timeout = 3;
+       char opt;
+    char ipaddr[INET6_ADDRSTRLEN];
+    void *addr;
+    struct addrinfo *res, *rp;
+       struct sigaction sa = { .sa_handler = &abort_query };
+    struct addrinfo hints = {
+       .ai_family   = AF_UNSPEC,
+       .ai_socktype = SOCK_STREAM,
+       .ai_protocol = IPPROTO_TCP,
+       .ai_flags    = 0
+    };
+
+       while ((opt = getopt(argc, argv, "46t:h")) > -1)
+       {
+               switch (opt)
+               {
+                       case '4':
+                               hints.ai_family = AF_INET;
+                               break;
+
+                       case '6':
+                               hints.ai_family = AF_INET6;
+                               break;
+
+                       case 't':
+                               timeout = atoi(optarg);
+                               if (timeout <= 0)
+                                       show_usage();
+                               break;
+
+                       case 'h':
+                               show_usage();
+                               break;
+               }
+       }
+
+       if (!argv[optind])
+               show_usage();
+
+       sigaction(SIGALRM, &sa, NULL);
+       alarm(timeout);
+
+       if (getaddrinfo(argv[optind], NULL, &hints, &res))
+               exit(2);
+
+    for (rp = res; rp != NULL; rp = rp->ai_next)
+    {
+               addr = (rp->ai_family == AF_INET)
+                       ? (void *)&((struct sockaddr_in *)rp->ai_addr)->sin_addr
+                       : (void *)&((struct sockaddr_in6 *)rp->ai_addr)->sin6_addr
+               ;
+
+               if (!inet_ntop(rp->ai_family, addr, ipaddr, INET6_ADDRSTRLEN - 1))
+                       exit(3);
+
+               printf("%s\n", ipaddr);
+       }
+
+       freeaddrinfo(res);
+       exit(0);
+}