this patch fixes gdb parallel build.
authorthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Mar 2010 01:50:53 +0000 (01:50 +0000)
committerthepeople <thepeople@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Mar 2010 01:50:53 +0000 (01:50 +0000)
-Raphael

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20187 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/gdb/Makefile

index 6a166d0eb7606c89a3cea8c2e2152e0cc71c4dc2..5044033a21df133aa082e32e8258dc5c59c599d7 100644 (file)
@@ -1,4 +1,5 @@
-# Copyright (C) 2006-2009 OpenWrt.org
+#
+# Copyright (C) 2006-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=gdb
 PKG_VERSION:=6.8
-PKG_RELEASE:=1
+PKG_RELEASE:=2
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=@GNU/gdb
@@ -19,17 +20,19 @@ include $(INCLUDE_DIR)/package.mk
 define Package/gdb/Default
   SECTION:=utils
   CATEGORY:=Utilities
-  DEPENDS:= @!(avr32||cris)
+  DEPENDS:=@!(avr32||cris)
 endef
 
 define Package/gdb
 $(call Package/gdb/Default)
   TITLE:=GNU Debugger
-  DEPENDS+= +libreadline +libncurses
+  DEPENDS+=+libreadline +libncurses
 endef
 
 define Package/gdb/description
- GNU debugger
+GDB, the GNU Project debugger, allows you to see what is going on `inside'
+another program while it executes -- or what another program was doing at the
+moment it crashed.
 endef
 
 define Package/gdbserver
@@ -38,14 +41,14 @@ $(call Package/gdb/Default)
 endef
 
 define Package/gdbserver/description
- GDBSERVER is a program that allows you to run GDB on a different machine 
- than the one which is running the program being debugged.
+GDBSERVER is a program that allows you to run GDB on a different machine than the
+one which is running the program being debugged.
 endef
 
 # XXX: add --disable-werror to prevent build failure with arm
 CONFIGURE_ARGS+= \
        --with-system-readline \
-       --disable-werror \
+       --disable-werror
 
 CONFIGURE_VARS+= \
        ac_cv_search_tgetent="$(TARGET_LDFLAGS) -lncurses -lreadline"
@@ -54,19 +57,22 @@ define Build/Compile
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
                CPPFLAGS="$(TARGET_CPPFLAGS)" \
-               all install-gdb
+               all
+       $(MAKE) -C $(PKG_BUILD_DIR) \
+               DESTDIR="$(PKG_INSTALL_DIR)" \
+               CPPFLAGS="$(TARGET_CPPFLAGS)" \
+               install-gdb
 endef
 
-define Package/gdb/install     
+define Package/gdb/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdb $(1)/usr/bin/
 endef
 
-define Package/gdbserver/install       
+define Package/gdbserver/install
        $(INSTALL_DIR) $(1)/usr/bin
        $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/gdbserver $(1)/usr/bin/
 endef
 
 $(eval $(call BuildPackage,gdb))
 $(eval $(call BuildPackage,gdbserver))
-