ixp4xx: Initial profile for the Freecom FSG-3
authorrwhitby <rwhitby@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Jul 2007 13:29:57 +0000 (13:29 +0000)
committerrwhitby <rwhitby@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 11 Jul 2007 13:29:57 +0000 (13:29 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7920 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ixp4xx-2.6/config/profile-FSG3 [new file with mode: 0644]
target/linux/ixp4xx-2.6/profiles/500-FSG3.mk [new file with mode: 0644]

diff --git a/target/linux/ixp4xx-2.6/config/profile-FSG3 b/target/linux/ixp4xx-2.6/config/profile-FSG3
new file mode 100644 (file)
index 0000000..051031d
--- /dev/null
@@ -0,0 +1,16 @@
+CONFIG_CMDLINE="root=/dev/sda1 noinitrd console=ttyS0,115200"
+CONFIG_ATA=y
+CONFIG_SATA_VIA=y
+CONFIG_USB_EHCI_HCD=y
+CONFIG_USB_EHCI_SPLIT_ISO=y
+CONFIG_USB_EHCI_ROOT_HUB_TT=y
+CONFIG_USB_EHCI_TT_NEWSCHED=y
+CONFIG_USB_OHCI_HCD=y
+CONFIG_USB_OHCI_LITTLE_ENDIAN=y
+CONFIG_USB_STORAGE=y
+CONFIG_EXT3_FS=y
+CONFIG_EXT3_FS_XATTR=y
+CONFIG_EXT3_FS_POSIX_ACL=y
+CONFIG_EXT3_FS_SECURITY=y
+CONFIG_JBD=y
+CONFIG_FS_MBCACHE=y
diff --git a/target/linux/ixp4xx-2.6/profiles/500-FSG3.mk b/target/linux/ixp4xx-2.6/profiles/500-FSG3.mk
new file mode 100644 (file)
index 0000000..d7d6a2e
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/FSG3
+  NAME:=Freecom FSG-3
+  PACKAGES:= \
+       kmod-madwifi wireless-tools \
+       kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
+       kmod-fs-ext2
+endef
+
+define Profile/FSG3/Description
+       Package set optimized for the Freecom FSG-3
+endef
+$(eval $(call Profile,FSG3))
+