use separate sysctl.conf files for 2.4 and 2.6 - fixes some boot message spam
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Apr 2007 12:05:52 +0000 (12:05 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Apr 2007 12:05:52 +0000 (12:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@7043 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
target/linux/generic-2.4/base-files/etc/sysctl.conf [moved from package/base-files/files/etc/sysctl.conf with 100% similarity]
target/linux/generic-2.6/base-files/etc/sysctl.conf [new file with mode: 0644]

index 1e1610c5d739fa92e473521902aedd67412de9ba..e267b7f78b67bb876e7735f796c660877bf9dea3 100644 (file)
@@ -13,7 +13,7 @@ PKG_NAME:=base-files
 PKG_RELEASE:=8
 
 PKG_BUILD_DIR:=$(KERNEL_BUILD_DIR)/$(PKG_NAME)
-PKG_FILE_DEPEND:=$(PLATFORM_DIR)
+PKG_FILE_DEPEND:=$(PLATFORM_DIR) $(GENERIC_PLATFORM_DIR)/base-files
 
 REV:=$(shell LANG=C svn info | awk '/^Revision:/ { print$$2 }' )
 ifeq ($(REV),)
@@ -110,6 +110,9 @@ endef
 
 define Package/base-files$(TARGET)/install
        $(CP) ./files/* $(1)/
+       if [ -d $(GENERIC_PLATFORM_DIR)/base-files/. ]; then \
+               $(CP) $(GENERIC_PLATFORM_DIR)/base-files/* $(1)/; \
+       fi
        if [ -d $(PLATFORM_DIR)/base-files/default/. ]; then \
                $(CP) $(PLATFORM_DIR)/base-files/default/* $(1)/; \
        fi
diff --git a/target/linux/generic-2.6/base-files/etc/sysctl.conf b/target/linux/generic-2.6/base-files/etc/sysctl.conf
new file mode 100644 (file)
index 0000000..a05498c
--- /dev/null
@@ -0,0 +1,10 @@
+kernel.panic=3
+net.ipv4.conf.default.arp_ignore=1
+net.ipv4.conf.all.arp_ignore=1
+net.ipv4.ip_forward=1
+net.ipv4.icmp_echo_ignore_broadcasts=1
+net.ipv4.icmp_ignore_bogus_error_responses=1
+net.ipv4.tcp_fin_timeout=30
+net.ipv4.tcp_keepalive_time=120
+net.ipv4.tcp_syncookies=1
+net.ipv4.tcp_timestamps=0