fix download reverse depends
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Mar 2009 02:37:10 +0000 (02:37 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 17 Mar 2009 02:37:10 +0000 (02:37 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14907 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/download.mk

index 811c42a3c37e249974b76197e4899d34f17ae7f9..78848b9c956d2004071c600bf51bcd8c8bbd1c30 100644 (file)
@@ -5,7 +5,7 @@
 # See /LICENSE for more information.
 #
 
-DOWNLOAD_RDEP:=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
+DOWNLOAD_RDEP=$(STAMP_PREPARED) $(HOST_STAMP_PREPARED)
 
 # Try to guess the download method from the URL
 define dl_method 
@@ -132,7 +132,9 @@ define Download
     endif
   )
 
-  $(if $(DOWNLOAD_RDEP),$(DOWNLOAD_RDEP): $(DL_DIR)/$(FILE))
+  $(foreach dep,$(DOWNLOAD_RDEP),
+    $(dep): $(DL_DIR)/$(FILE)
+  )
   download: $(DL_DIR)/$(FILE)
 
   $(DL_DIR)/$(FILE):