hostapd: fix compile error in the roboswitch driver
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Jan 2010 15:12:57 +0000 (15:12 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Jan 2010 15:12:57 +0000 (15:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19290 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hostapd/Makefile
package/hostapd/patches/340-roboswitch_fix.patch [new file with mode: 0644]

index 95b34141e7888a9ffb54606dfe5935251aabfb41..93392110ab1ce117aa2b9a0c19349957105d665f 100644 (file)
@@ -54,7 +54,6 @@ DRIVER_MAKEOPTS= \
        CONFIG_DRIVER_NL80211=$(CONFIG_PACKAGE_kmod-mac80211) \
        CONFIG_DRIVER_MADWIFI=$(CONFIG_PACKAGE_kmod-madwifi) \
        CONFIG_DRIVER_HOSTAP=$(CONFIG_PACKAGE_kmod-hostap) \
-       CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch) \
        CONFIG_IEEE80211N=$(CONFIG_PACKAGE_kmod-ath9k)
 
 ifeq ($(LOCAL_TYPE),supplicant)
@@ -66,6 +65,8 @@ endif
 ifneq ($(LOCAL_TYPE),hostapd)
   ifdef CONFIG_WPA_SUPPLICANT_NO_TIMESTAMP_CHECK
     TARGET_CFLAGS += -DNO_TIMESTAMP_CHECK
+    DRIVER_MAKEOPTS += \
+               CONFIG_DRIVER_ROBOSWITCH=$(CONFIG_PACKAGE_kmod-switch)
   endif
 endif
 
diff --git a/package/hostapd/patches/340-roboswitch_fix.patch b/package/hostapd/patches/340-roboswitch_fix.patch
new file mode 100644 (file)
index 0000000..50dca64
--- /dev/null
@@ -0,0 +1,14 @@
+--- a/src/drivers/driver_roboswitch.c
++++ b/src/drivers/driver_roboswitch.c
+@@ -14,10 +14,10 @@
+ #include "includes.h"
+ #include <sys/ioctl.h>
+-#include <linux/if.h>
+ #include <linux/sockios.h>
+ #include <linux/if_ether.h>
+ #include <linux/mii.h>
++#include <net/if.h>
+ #include "common.h"
+ #include "driver.h"