add uci v0.2 - implements batch mode and a command for listing changes to a package
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Feb 2008 00:34:17 +0000 (00:34 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 5 Feb 2008 00:34:17 +0000 (00:34 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10386 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uci/Makefile

index 651215001c2c666a06342014a9291024e02a0365..8e654e76a21c7f4ce6fca125bd4eb809e4ffcda0 100644 (file)
@@ -8,15 +8,17 @@
 
 include $(TOPDIR)/rules.mk
 
+UCI_VERSION=0.2
+UCI_RELEASE=
+
 PKG_NAME:=uci
-PKG_VERSION:=0.1.2
+PKG_VERSION:=$(UCI_VERSION)$(UCI_RELEASE)
 PKG_RELEASE:=1
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=http://downloads.openwrt.org/sources
-PKG_MD5SUM:=2c1bd1b24ca3c3e565b28122f2efd047
+PKG_MD5SUM:=8cb8e1e511d1a34372bf9f3239624433
 
-LIBVERSION=0.1
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -51,7 +53,7 @@ define Build/Compile
                $(TARGET_CONFIGURE_OPTS) \
                COPTS="$(TARGET_CFLAGS)" \
                DEBUG="$(DEBUG)" \
-               VERSION="$(LIBVERSION)" \
+               VERSION="$(UCI_VERSION)" \
                OS="Linux"
 endef