readd $(HOST_CONFIGURE_VARS) to Host/Configure/Default, missed in r14699
authoragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Mar 2009 03:03:21 +0000 (03:03 +0000)
committeragb <agb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 2 Mar 2009 03:03:21 +0000 (03:03 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14724 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host-build.mk

index 8ad8f79d96007715c91b8bcbe07fa0108a100097..57cb3002b5fa0a2dc212e8be32cce760a1b89f57 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006-2008 OpenWrt.org
+#
+# Copyright (C) 2006-2009 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -25,7 +25,7 @@ include $(INCLUDE_DIR)/quilt.mk
 Host/Patch:=$(Host/Patch/Default)
 ifneq ($(strip $(HOST_UNPACK)),)
   define Host/Prepare/Default
-       $(HOST_UNPACK)
+       $(HOST_UNPACK)
        $(Host/Patch)
   endef
 endif
@@ -58,6 +58,7 @@ define Host/Configure/Default
                        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/$(3)/ && \
                        $(2) \
                        $(HOST_CONFIGURE_CMD) \
+                       $(HOST_CONFIGURE_VARS) \
                        $(HOST_CONFIGURE_ARGS) \
                        $(1); \
                fi \
@@ -97,7 +98,7 @@ ifndef DUMP
   $(if $(QUILT),$(Host/Quilt))
   $(if $(STAMP_PREPARED),,$(if $(strip $(PKG_SOURCE_URL)),$(call Download,default)))
   $(if $(DUMP),,$(call HostHost/Autoclean))
-  
+
   $(HOST_STAMP_PREPARED):
        @-rm -rf $(HOST_BUILD_DIR)
        @mkdir -p $(HOST_BUILD_DIR)
@@ -116,7 +117,7 @@ ifndef DUMP
        $(call Host/Install)
        mkdir -p $$(shell dirname $$@)
        touch $$@
-       
+
   ifdef Host/Install
     host-install: $(HOST_STAMP_INSTALLED)
   endif