fix unnecessary kernel package recompile
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Oct 2006 06:38:06 +0000 (06:38 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 19 Oct 2006 06:38:06 +0000 (06:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5227 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package.mk

index 05b4ffd2dcdc8d0cc72811f8c10e03d2873e69a6..b4f16e2d3ac90cadefb42fa1b3a6cafcc81a1681 100644 (file)
@@ -256,16 +256,18 @@ define BuildPackage
 
   $$(eval $$(call Build/DefaultTargets,$(1)))
 
-  ifneq ($$(CONFIG_PACKAGE_$(1)),)
-    ifneq ($(MAKECMDGOALS),prereq)
-      ifneq ($(DUMP),1)
-        ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
-          _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
-          $(PKG_BUILD_DIR)/.built: package-rebuild
-        endif
-
-        ifneq ($$(_INFO),)
-          $$(info Rebuilding $$(_INFO))
+  ifdef Package/$(1)/install
+    ifneq ($$(CONFIG_PACKAGE_$(1)),)
+      ifneq ($(MAKECMDGOALS),prereq)
+        ifneq ($(DUMP),1)
+          ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))
+            _INFO+=$(subst $(TOPDIR)/,,$$(IPKG_$(1)))
+            $(PKG_BUILD_DIR)/.built: package-rebuild
+          endif
+
+          ifneq ($$(_INFO),)
+            $$(info Rebuilding $$(_INFO))
+          endif
         endif
       endif
     endif