build all packages in a package directory by default if DEVELOPER or SDK is set
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 30 Nov 2006 21:39:37 +0000 (21:39 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 30 Nov 2006 21:39:37 +0000 (21:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5684 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/package.mk

index 648bda8dea6ae4e22990186ab92cec668541c849..cf8771a5ef89b6f5152a6e68d3ae4cf6264de777 100644 (file)
@@ -127,7 +127,7 @@ define BuildPackage
       install-targets: $$(INFO_$(1))
     endif
 
-    ifneq ($(CONFIG_PACKAGE_$(1)),)
+    ifneq ($(CONFIG_PACKAGE_$(1))$(DEVELOPER)$(SDK),)
       compile-targets: $$(IPKG_$(1))
     else
       compile-targets: $(1)-disabled
@@ -257,7 +257,7 @@ define BuildPackage
   $$(eval $$(call Build/DefaultTargets,$(1)))
 
   ifdef Package/$(1)/install
-    ifneq ($$(CONFIG_PACKAGE_$(1)),)
+    ifneq ($$(CONFIG_PACKAGE_$(1))$(DEVELOPER)$(SDK),)
       ifneq ($(MAKECMDGOALS),prereq)
         ifneq ($(DUMP),1)
           ifneq ($$(shell $(SCRIPT_DIR)/timestamp.pl -p -x ipkg -x ipkg-install '$$(IPKG_$(1))' '$(PKG_BUILD_DIR)'),$$(IPKG_$(1)))