fix gcc compile
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Oct 2006 19:55:54 +0000 (19:55 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 10 Oct 2006 19:55:54 +0000 (19:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@5032 3c298f89-4303-0410-b956-a3cf2f4a3e73

rules.mk
toolchain/gcc/Makefile

index 8e5294edb3ad69ccbd3b218922a0449c368b8995..b9859dbd3f66e9b653e56331a9ed05319d8fc341 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -8,7 +8,9 @@
 -include $(TOPDIR)/.config
 include $(TOPDIR)/include/verbose.mk
 
-export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"'  --
+export SHELL=/usr/bin/env bash -c '. $(TOPDIR)/include/shell.sh; eval "$$2"' --
+export BASH=$(shell which bash)
+
 ARCH:=$(strip $(subst ",, $(CONFIG_ARCH)))
 TARGET_OPTIMIZATION:=$(strip $(subst ",, $(CONFIG_TARGET_OPTIMIZATION)))
 WGET:=$(strip $(subst ",, $(CONFIG_WGET)))
index 8a2337593382ee33ef93e34b1525ed67dad3301d..7ef6005d06ba901e4d26c43ff9a3a273e8f24c5e 100644 (file)
@@ -45,6 +45,7 @@ include $(INCLUDE_DIR)/host-build.mk
 BUILD_DIR1:=$(TOOLCHAIN_BUILD_DIR)/gcc-$(PKG_VERSION)-initial
 BUILD_DIR2:=$(TOOLCHAIN_BUILD_DIR)/gcc-$(PKG_VERSION)-final
 
+override SHELL:=$(BASH)
 
 define Stage1/Configure
        mkdir -p $(BUILD_DIR1)