opkg: apparently array bounds checking is gcc 4.3 specific, move -Wno-array-bounds...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Feb 2009 14:11:12 +0000 (14:11 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 14 Feb 2009 14:11:12 +0000 (14:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14508 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/opkg/Makefile
package/opkg/patches/005-array_warnings.patch [deleted file]

index 91db7247676355b3067bccbf84aab39a7733628d..6a857905b71bc41cb68683d6959e3b4892350f2e 100644 (file)
@@ -40,7 +40,7 @@ define Package/opkg/conffiles
 /etc/opkg.conf
 endef
 
-TARGET_CFLAGS += $(FPIC)
+TARGET_CFLAGS += $(FPIC) $(if $(CONFIG_GCC_VERSION_4_3),-Wno-array-bounds)
 EXTRA_CFLAGS+=-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/lib
 EXTRA_LDFLAGS+=-L$(STAGING_DIR)/usr/lib -Wl,-rpath-link,$(STAGING_DIR)/usr/lib
 
diff --git a/package/opkg/patches/005-array_warnings.patch b/package/opkg/patches/005-array_warnings.patch
deleted file mode 100644 (file)
index deaffbe..0000000
+++ /dev/null
@@ -1,10 +0,0 @@
---- a/libopkg/Makefile.am
-+++ b/libopkg/Makefile.am
-@@ -1,6 +1,6 @@
- HOST_CPU=@host_cpu@
--AM_CFLAGS=-Wall -Werror -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
-+AM_CFLAGS=-Wall -Werror -Wno-array-bounds -DHOST_CPU_STR=\"$(HOST_CPU)\" -DBUILD_CPU=@build_cpu@ -DLIBDIR=\"@libdir@\" -DOPKGLIBDIR=\"@opkglibdir@\" -DDATADIR=\"@datadir@\" -I$(top_srcdir) $(BIGENDIAN_CFLAGS) $(CURL_CFLAGS) $(GPGME_CFLAGS)
- libopkg_includedir=$(includedir)/libopkg
- libopkg_include_HEADERS= opkg.h