mmc_over_gpio: Add initscript that will create a device
authormb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Mar 2008 17:38:16 +0000 (17:38 +0000)
committermb <mb@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 21 Mar 2008 17:38:16 +0000 (17:38 +0000)
Note that we should use a config file where we can define an arbitrary number of devices.

git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10638 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/mmc_over_gpio/Makefile
package/mmc_over_gpio/files/mmc_over_gpio.init [new file with mode: 0644]

index 9076525b03e99732635fafe7aea32bfb625f63dc..d38fa416e5da9e486973e16fb65fe5621f11a792 100644 (file)
@@ -3,8 +3,6 @@
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
-#
-# $Id: Makefile 10138 2008-01-06 19:28:26Z nbd $
 
 #XXX This package will go away once the stuff is merged into the kernel.
 
@@ -44,4 +42,9 @@ define Build/Compile
                modules
 endef
 
+define KernelPackage/mmc-over-gpio/install
+       $(INSTALL_DIR) $(1)/etc/init.d
+       $(INSTALL_BIN) ./files/mmc_over_gpio.init $(1)/etc/init.d/mmc_over_gpio
+endef
+
 $(eval $(call KernelPackage,mmc-over-gpio))
diff --git a/package/mmc_over_gpio/files/mmc_over_gpio.init b/package/mmc_over_gpio/files/mmc_over_gpio.init
new file mode 100644 (file)
index 0000000..88d9e41
--- /dev/null
@@ -0,0 +1,25 @@
+#!/bin/sh /etc/rc.common
+# Copyright (C) 2008 OpenWrt.org
+START=90
+
+SYSFS="/sys"
+SYSFS_DRIVERDIR="$SYSFS/bus/platform/drivers/spi-gpio-mmc"
+
+# add_device(name, DI_pin, DO_pin, CLK_pin, CS_pin, mode)
+add_device() {
+       echo -n "$1" "$2","$3","$4","$5" "$6" > $SYSFS_DRIVERDIR/add
+}
+
+# remove_device(name)
+remove_device() {
+       echo -n "$1" > $SYSFS_DRIVERDIR/remove
+}
+
+start() {
+       #FIXME we should use a config file, but I dunno how that parser works.
+       add_device "default" 5 4 3 7 0
+}
+
+stop() {
+       remove_device "default"
+}