properly clean up after kernel_{old,menu}config
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 11 Sep 2007 00:14:37 +0000 (00:14 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 11 Sep 2007 00:14:37 +0000 (00:14 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@8737 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/kernel-build.mk

index 8d8a587bddeda7908deb31be7976f7fdcb8796b2..3b767c382bba22458e94d1087313ff5a214eb09d 100644 (file)
@@ -77,10 +77,10 @@ define BuildKernel
        $(MAKE) -C image compile TARGET_BUILD=
 
   oldconfig menuconfig: $(STAMP_PREPARED) FORCE
-       $(Kernel/Configure)
        $(LINUX_CONFCMD) > $(LINUX_DIR)/.config
        $(MAKE) -C $(LINUX_DIR) $(KERNEL_MAKEOPTS) $$@
        $(SCRIPT_DIR)/kconfig.pl '>' $(GENERIC_LINUX_CONFIG) $(LINUX_DIR)/.config > $(LINUX_CONFIG)
+       $(Kernel/Configure)
 
   install: $(LINUX_DIR)/.image
        TARGET_BUILD="" $(MAKE) -C image compile install