add kernel packages for the ixp4xx-beeper and appletalk -- closes #6618
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 2 Feb 2010 11:26:53 +0000 (11:26 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 2 Feb 2010 11:26:53 +0000 (11:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19497 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/netsupport.mk
package/kernel/modules/other.mk

index 21abc4c863b92308c0ad3296f409081eb789dbc9..9e9cdcbb637a3ecd05c7067df70093b7f361e533 100644 (file)
@@ -43,6 +43,29 @@ endef
 $(eval $(call KernelPackage,atmtcp))
 
 
+define KernelPackage/appletalk
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=Appletalk protocol support
+  DEPENDS:=@LINUX_2_6
+  KCONFIG:= \
+       CONFIG_ATALK \
+       CONFIG_DEV_APPLETALK \
+       CONFIG_IPDDP \
+       CONFIG_IPDDP_ENCAP=y \
+       CONFIG_IPDDP_DECAP=y
+  FILES:= \
+       $(LINUX_DIR)/net/appletalk/appletalk.$(LINUX_KMOD_SUFFIX) \
+       $(LINUX_DIR)/drivers/net/appletalk/ipddp.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,40,appletalk ipddp)
+endef
+
+define KernelPackage/appletalk/description
+ Kernel module for AppleTalk protocol.
+endef
+
+$(eval $(call KernelPackage,appletalk))
+
+
 define KernelPackage/bonding
   SUBMENU:=$(NETWORK_SUPPORT_MENU)
   TITLE:=Ethernet bonding driver
index f6c73c04906bbc9ab254b3bd753eb299c6ff3826..47fee9f53c0a21dda7114389cbffcb0fb268f7c6 100644 (file)
@@ -785,6 +785,24 @@ endef
 $(eval $(call KernelPackage,cs5535-gpio))
 
 
+define KernelPackage/ixp4xx-beeper
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=IXP4XX Beeper support
+  DEPENDS:=@TARGET_ixp4xx +kmod-input-core
+  KCONFIG:= \
+       CONFIG_INPUT_MISC=y \
+       CONFIG_INPUT_IXP4XX_BEEPER
+  FILES:=$(LINUX_DIR)/drivers/input/misc/ixp4xx-beeper.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,ixp4xx-beeper)
+endef
+
+define KernelPackage/ixp4xx-beeper/description
+ IXP4XX Beeper support
+endef
+
+$(eval $(call KernelPackage,ixp4xx-beeper))
+
+
 define KernelPackage/textsearch
 SUBMENU:=$(OTHER_MENU)
   TITLE:=Textsearch support is selected if needed