add _GNU_SOURCE to CPPFLAGS required to include <bits/socket.h> on recent eglibc...
authornico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Sep 2009 19:01:50 +0000 (19:01 +0000)
committernico <nico@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 26 Sep 2009 19:01:50 +0000 (19:01 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17749 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/swconfig/Makefile
package/wprobe/Makefile

index bec94a1ca0980ffe28f74a91ff4e40e215fe7ec1..a7bed73174d768f50bf25cfb158fcedb96d9a5cd 100644 (file)
@@ -21,6 +21,7 @@ define Package/swconfig
 endef
 
 TARGET_CPPFLAGS := \
 endef
 
 TARGET_CPPFLAGS := \
+       -D_GNU_SOURCE \
        -I$(STAGING_DIR)/usr/include/libnl-tiny \
        -I$(LINUX_DIR)/include \
        -I$(PKG_BUILD_DIR) \
        -I$(STAGING_DIR)/usr/include/libnl-tiny \
        -I$(LINUX_DIR)/include \
        -I$(PKG_BUILD_DIR) \
index 02e9919aa2250755dd61fa0a7c3b9f6fc67f0ea6..536a85eb2a7294424a901e4d6dd927cb295b7813 100644 (file)
@@ -61,6 +61,7 @@ define Build/Prepare
 endef
 
 TARGET_CPPFLAGS := \
 endef
 
 TARGET_CPPFLAGS := \
+       -D_GNU_SOURCE \
        -I$(STAGING_DIR)/usr/include/libnl-tiny \
        $(TARGET_CPPFLAGS)
 
        -I$(STAGING_DIR)/usr/include/libnl-tiny \
        $(TARGET_CPPFLAGS)