export the FIND variable which points to a usable find version
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Aug 2008 09:04:48 +0000 (09:04 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 17 Aug 2008 09:04:48 +0000 (09:04 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@12327 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/host.mk

index 9d40ec40a31b2487d9316534bf3991ab3d6a47c3..b6a58248fdb79f332ea9e60fc0bbf633469f3744 100644 (file)
@@ -8,7 +8,7 @@
 TMP_DIR ?= $(TOPDIR)/tmp
 -include $(TMP_DIR)/.host.mk
 
-export TAR
+export TAR FIND
 
 ifneq ($(__host_inc),1)
 __host_inc:=1
@@ -34,10 +34,10 @@ $(TMP_DIR)/.host.mk: $(TOPDIR)/include/host.mk
                [ -n "$$FIND" -a -x "$$FIND" ] || FIND=`which find 2>/dev/null`; \
                echo "FIND:=$$FIND" >> $@; \
                echo "BASH:=$(shell which bash)" >> $@; \
-               if find -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
-                       echo 'FIND_L=find -L $$(1)' >>$@; \
+               if $$FIND -L /tmp -maxdepth 0 >/dev/null 2>/dev/null; then \
+                       echo "FIND_L=$$FIND -L \$$(1)" >>$@; \
                else \
-                       echo 'FIND_L=find $$(1) -follow' >> $@; \
+                       echo "FIND_L=$$FIND \$$(1) -follow" >> $@; \
                fi; \
                if xargs --help 2>&1 | grep 'gnu.org' >/dev/null; then \
                        echo 'XARGS:=xargs -r' >> $@; \