[ar71xx] preliminary support for the Atheros AP81 refrence board
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 15 Mar 2009 14:30:08 +0000 (14:30 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 15 Mar 2009 14:30:08 +0000 (14:30 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@14888 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/config-2.6.28
target/linux/ar71xx/files/arch/mips/ar71xx/Kconfig
target/linux/ar71xx/files/arch/mips/ar71xx/Makefile
target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap81.c [new file with mode: 0644]
target/linux/ar71xx/files/arch/mips/ar71xx/prom.c
target/linux/ar71xx/files/arch/mips/include/asm/mach-ar71xx/ar71xx.h

index f885d6df08edd5d5118c9bcca197055fbf45f930..1015c8dcc9be9abac96b2d315d44d897e938e267 100644 (file)
@@ -6,6 +6,7 @@ CONFIG_AG71XX=y
 CONFIG_AG71XX_AR8216_SUPPORT=y
 # CONFIG_AG71XX_DEBUG is not set
 # CONFIG_AR71XX_EARLY_SERIAL is not set
+CONFIG_AR71XX_MACH_AP81=y
 CONFIG_AR71XX_MACH_AP83=y
 CONFIG_AR71XX_MACH_AW_NR580=y
 CONFIG_AR71XX_MACH_GENERIC=y
index e348c8852bc809bf2f0bef64901b36fc67480955..355a294e2b13ac47476798872f93d8b5f80d4041 100644 (file)
@@ -6,6 +6,10 @@ config AR71XX_EARLY_SERIAL
 
 menu "Atheros AR71xx machine selection"
 
+config AR71XX_MACH_AP81
+       bool "Atheros AP81 board support"
+       default y
+
 config AR71XX_MACH_AP83
        bool "Atheros AP83 board support"
        default y
index 0d2b3582046f4435a4fe936648b34301b6300a09..64030540ec5210b599c9596dfc48ab7148ad8448 100644 (file)
@@ -10,6 +10,7 @@
 
 obj-y  := prom.o irq.o setup.o devices.o gpio.o ar71xx.o
 
+obj-$(CONFIG_AR71XX_MACH_AP81)         += mach-ap81.o
 obj-$(CONFIG_AR71XX_MACH_AP83)         += mach-ap83.o
 obj-$(CONFIG_AR71XX_MACH_AW_NR580)     += mach-aw-nr580.o
 obj-$(CONFIG_AR71XX_MACH_GENERIC)      += mach-generic.o
diff --git a/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap81.c b/target/linux/ar71xx/files/arch/mips/ar71xx/mach-ap81.c
new file mode 100644 (file)
index 0000000..01504a7
--- /dev/null
@@ -0,0 +1,22 @@
+/*
+ *  Atheros AP81 board support
+ *
+ *  Copyright (C) 2009 Gabor Juhos <juhosg@openwrt.org>
+ *  Copyright (C) 2009 Imre Kaloz <kaloz@openwrt.org>
+ *
+ *  This program is free software; you can redistribute it and/or modify it
+ *  under the terms of the GNU General Public License version 2 as published
+ *  by the Free Software Foundation.
+ */
+
+#include <asm/mips_machine.h>
+#include <asm/mach-ar71xx/ar71xx.h>
+
+#include "devices.h"
+
+static void __init ap81_setup(void)
+{
+       ar91xx_add_device_wmac();
+}
+
+MIPS_MACHINE(AR71XX_MACH_AP81, "Atheros AP81", ap81_setup);
index aa4da8e2317331a497dc683db37751eb74e8a693..810b4747f143800b2978d37060c9b0e4b5428e51 100644 (file)
@@ -45,11 +45,14 @@ static struct board_rec boards[] __initdata = {
                .name           = "493",
                .mach_type      = AR71XX_MACH_RB_493,
        }, {
-               .name           = "AW-NR580",
-               .mach_type      = AR71XX_MACH_AW_NR580,
+               .name           = "AP81",
+               .mach_type      = AR71XX_MACH_AP81,
        }, {
                .name           = "AP83",
                .mach_type      = AR71XX_MACH_AP83,
+       }, {
+               .name           = "AW-NR580",
+               .mach_type      = AR71XX_MACH_AW_NR580,
        }, {
                .name           = "TEW-632BRP",
                .mach_type      = AR71XX_MACH_TEW_632BRP,
index f6acb11991b800784408ebb7e58178d7615d289a..52531ce0fbfb3a62c7577d338d947631a71f5511 100644 (file)
@@ -129,6 +129,7 @@ extern unsigned long ar71xx_mach_type;
 #define AR71XX_MACH_UBNT_LSSR71        15      /* Ubiquiti LS-SR71 */
 #define AR71XX_MACH_TL_WR941ND 16      /* TP-LINK TL-WR941ND */
 #define AR71XX_MACH_UBNT_RSPRO 17      /* Ubiquiti RouterStation Pro */
+#define AR71XX_MACH_AP81       18      /* Atheros AP81 */
 
 /*
  * PLL block