rename the xscale target to ixp4xx for the forthcoming iop target, add gcc 4.1 patch...
authorkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Oct 2006 10:26:00 +0000 (10:26 +0000)
committerkaloz <kaloz@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Fri, 27 Oct 2006 10:26:00 +0000 (10:26 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@5310 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/target.mk
target/Config.in
target/image/ixp4xx/Makefile [moved from target/image/xscale/Makefile with 100% similarity]
target/linux/ixp4xx-2.6/Makefile [moved from target/linux/xscale-2.6/Makefile with 100% similarity]
target/linux/ixp4xx-2.6/config [moved from target/linux/xscale-2.6/config with 100% similarity]
target/linux/ixp4xx-2.6/patches/001-gateway_7001.patch [moved from target/linux/xscale-2.6/patches/001-gateway_7001.patch with 100% similarity]
toolchain/gcc/Config.version
toolchain/uClibc/patches/170-arm_gcc41.patch [new file with mode: 0644]

index 55b6364289a4b0e740cff1d268f3ce98f9dc6c79..614ab06df8edbe0c0b32d02e109f6e42720fefda 100644 (file)
@@ -22,7 +22,7 @@ $(eval $(call kernel_template,2.6,uml,2_6_UML))
 $(eval $(call kernel_template,2.4,ar531x,2_4_AR531X))
 $(eval $(call kernel_template,2.6,aruba,2_6_ARUBA))
 $(eval $(call kernel_template,2.6,au1000,2_6_AU1000))
-$(eval $(call kernel_template,2.6,xscale,2_6_XSCALE))
+$(eval $(call kernel_template,2.6,ixp4xx,2_6_IXP4XX))
 $(eval $(call kernel_template,2.6,magicbox,2_6_MAGICBOX))
 $(eval $(call kernel_template,2.6,sibyte,2_6_SIBYTE))
 
index a69c2249fe496375d06c17d113cbda79e3c6ba84..647aa12b36b7ecccdfa81d0a7e4d96398e4d6746 100644 (file)
@@ -78,8 +78,8 @@ config LINUX_2_6_BRCM63XX
          Build firmware images for Broadcom based xDSL/routers
          (e.g. Inventel Livebox, Siemens SE515)
 
-config LINUX_2_6_XSCALE
-       bool "Intel XScale [2.6]"
+config LINUX_2_6_IXP4XX
+       bool "Intel XScale IXP4xx [2.6]"
        select armeb
        select LINUX_2_6
        select PCI_SUPPORT
index af5e10280775ab493e0cd458464a469aaff6c519..f4d71971a66c23352268df74d7ea8b29ea87aa20 100644 (file)
@@ -12,9 +12,7 @@ config GCC_VERSION
 
 if !TOOLCHAINOPTS
        config GCC_VERSION_4_1_1
-               default y if LINUX_2_6_ARUBA || LINUX_2_6_X86 || LINUX_2_6_RB532
-       config GCC_VERSION_4_0_3
-               default y if LINUX_2_6_XSCALE
+               default y if LINUX_2_6_ARUBA || LINUX_2_6_X86 || LINUX_2_6_RB532 || LINUX_2_6_IXP4XX
 endif
 
 
diff --git a/toolchain/uClibc/patches/170-arm_gcc41.patch b/toolchain/uClibc/patches/170-arm_gcc41.patch
new file mode 100644 (file)
index 0000000..795efbd
--- /dev/null
@@ -0,0 +1,13 @@
+diff -ur uClibc-0.9.28/ldso/include/dl-string.h uClibc-0.9.28-owrt/ldso/include/dl-string.h
+--- uClibc-0.9.28/ldso/include/dl-string.h     2005-08-18 00:49:41.000000000 +0200
++++ uClibc-0.9.28-owrt/ldso/include/dl-string.h        2006-09-11 11:42:08.000000000 +0200
+@@ -228,7 +228,8 @@
+           char temp;
+           do_rem(temp, i, 10);
+           *--p = '0' + temp;
+-          i /= 10;
++          i /= 2;
++          i *= -(-1ul / 5ul);
+       } while (i > 0);
+       return p;
+ }