[package] iptables: disable kernel module autoloading
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Feb 2010 19:12:47 +0000 (19:12 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 28 Feb 2010 19:12:47 +0000 (19:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19917 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/iptables/Makefile
package/iptables/patches/020-iptables-disable-modprobe.patch [new file with mode: 0644]
package/iptables/patches/020-iptables-force-modprobe-util.patch [deleted file]

index 68ccc76282ac422ea09761878a152c41443ff33d..20e4b315caa5f915e230716f2b07453439040c41 100644 (file)
@@ -254,10 +254,6 @@ TARGET_CPPFLAGS := \
        -I$(LINUX_DIR)/arch/$(LINUX_KARCH)/include \
        $(TARGET_CPPFLAGS)
 
-TARGET_CFLAGS := \
-       $(TARGET_CFLAGS) \
-       -DFORCE_MODPROBE_PROGRAM="\\\"/sbin/insmod\\\""
-
 CONFIGURE_ARGS += \
        --enable-shared \
        --enable-devel \
diff --git a/package/iptables/patches/020-iptables-disable-modprobe.patch b/package/iptables/patches/020-iptables-disable-modprobe.patch
new file mode 100644 (file)
index 0000000..a6b5d1b
--- /dev/null
@@ -0,0 +1,18 @@
+--- a/xtables.c
++++ b/xtables.c
+@@ -313,6 +313,7 @@ static char *get_modprobe(void)
+ int xtables_insmod(const char *modname, const char *modprobe, bool quiet)
+ {
++#if 0
+       char *buf = NULL;
+       char *argv[4];
+       int status;
+@@ -356,6 +357,7 @@ int xtables_insmod(const char *modname, 
+       free(buf);
+       if (WIFEXITED(status) && WEXITSTATUS(status) == 0)
+               return 0;
++#endif
+       return -1;
+ }
diff --git a/package/iptables/patches/020-iptables-force-modprobe-util.patch b/package/iptables/patches/020-iptables-force-modprobe-util.patch
deleted file mode 100644 (file)
index 32c9fcd..0000000
+++ /dev/null
@@ -1,20 +0,0 @@
---- a/xtables.c
-+++ b/xtables.c
-@@ -285,6 +285,7 @@ void *xtables_realloc(void *ptr, size_t 
- static char *get_modprobe(void)
- {
-+#ifndef FORCE_MODPROBE_PROGRAM
-       int procfile;
-       char *ret;
-@@ -309,6 +310,9 @@ static char *get_modprobe(void)
-       free(ret);
-       close(procfile);
-       return NULL;
-+#else
-+      return strdup(FORCE_MODPROBE_PROGRAM);
-+#endif
- }
- int xtables_insmod(const char *modname, const char *modprobe, bool quiet)