fix a few bugs with the last few commits
authormbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Apr 2007 15:11:17 +0000 (15:11 +0000)
committermbm <mbm@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 7 Apr 2007 15:11:17 +0000 (15:11 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6887 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile

index e2d5c1450f2a341a274b648b27c65527a7947158..3187f72ee7846a03fcb0e35bd798f3a4d70c13e3 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -47,17 +47,17 @@ endif
 package/%/Makefile: ;
 target/%/Makefile: ;
 
-tmp/.packageinfo: FORCE
-tmp/.targetinfo: FORCE
+tmp/.packageinfo: $(wildcard package/*/Makefile include/package*.mk include/kernel.mk) FORCE
+tmp/.targetinfo: $(wildcard target/*/Makefile include/kernel*.mk)  FORCE
 tmp/.%info:
-       @mkdir -p tmp/info
-       @$(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$*info" SCAN_DIR="$(patsubst target,target/linux,$*)" SCAN_NAME="$*" SCAN_DEPS="$^" SCAN_EXTRA=""
+       mkdir -p tmp/info
+       $(NO_TRACE_MAKE) -s -f include/scan.mk SCAN_TARGET="$*info" SCAN_DIR="$(patsubst target,target/linux,$*)" SCAN_NAME="$*" SCAN_DEPS="$(filter FORCE, $^)" SCAN_EXTRA=""
 
 tmpinfo-clean: FORCE
        -rm -rf tmp/.*info
 
 tmp/.config-%.in: tmp/.%info
-       @./scripts/metadata.pl $*_config < $< > $@ || rm -f $@
+       ./scripts/metadata.pl $*_config < $< > $@ || rm -f $@
 
 .config: ./scripts/config/conf tmp/.config-target.in tmp/.config-package.in
        if [ \! -f .config ]; then \
@@ -160,6 +160,6 @@ docclean:
 symlinkclean:
        find package -type l -exec rm -f {} +
 
-.SILENT: clean dirclean distclean symlinkclean config-clean download world help tmp/.%info tmpinfo-clean tmp/.config-%.in .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-%
+.SILENT: clean dirclean distclean symlinkclean config-clean download world help tmp/.packageinfo tmp/.targetinfo tmpinfo-clean tmp/.config-package.in tmp/.config-target.in .config scripts/config/mconf scripts/config/conf menuconfig tmp/.prereq-build tmp/.prereq-package tmp/.prereq-target
 FORCE: ;
 .PHONY: FORCE help