move ccache dir to staging_dir_arch (removing the staging dir will make the ccache...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 Oct 2006 18:17:53 +0000 (18:17 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 9 Oct 2006 18:17:53 +0000 (18:17 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/buildroot-ng/openwrt@4999 3c298f89-4303-0410-b956-a3cf2f4a3e73

Makefile
rules.mk

index 89ca7d38b63bf69e640cd9fe91ef7f13549f4def..ed1e34db474f93dc62991a476afb813f300d52d6 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -132,7 +132,7 @@ dirclean: clean
        rm -rf staging_dir_* toolchain_build_* tool_build
 
 distclean: dirclean config-clean
-       rm -rf dl .*config* .pkg* .prereq ccache_*
+       rm -rf dl .*config* .pkg* .prereq 
 
 .SILENT: clean dirclean distclean config-clean download world
 FORCE: ;
index eebc758224c6d811f761cbf6fb6470e05623fb0a..0ec5daf086e354ba60fc884dabbf7a0c2da2fcc7 100644 (file)
--- a/rules.mk
+++ b/rules.mk
@@ -60,7 +60,7 @@ CP:=cp -fpR
 
 ifneq ($(CONFIG_CCACHE),)
   # FIXME: move this variable to a better location
-  export CCACHE_DIR=$(TOPDIR)/ccache_$(ARCH)
+  export CCACHE_DIR=$(STAGING_DIR)/ccache
   TARGET_CC:= ccache $(TARGET_CC)
 endif