backfire: ar71xx: build separate image for the WNDR3700 with NA region (backport...
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Mar 2011 14:53:50 +0000 (14:53 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 13 Mar 2011 14:53:50 +0000 (14:53 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@26113 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/image/Makefile

index e314ebb8c032fcab1b2e6d01374897c35a5d88a2..00cf6024f3382a8ad55b27372a6956a6251d0aac 100644 (file)
@@ -348,6 +348,10 @@ define Image/Build/WNDR3700
                -B WNDR3700 -v OpenWrt.$(REVISION) \
                -i $(call imgname,$(1),$(2))-sysupgrade.bin \
                -o $(call imgname,$(1),$(2))-factory.img
+       $(STAGING_DIR_HOST)/bin/mkdniimg \
+               -B WNDR3700 -v OpenWrt.$(REVISION) -r "NA" \
+               -i $(call imgname,$(1),$(2))-sysupgrade.bin \
+               -o $(call imgname,$(1),$(2))-factory-NA.img
 endef
 
 define Image/Build/WNDR3700/initramfs