hostap-driver: fix DEPENDS on Makefile
authoracoul <acoul@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 22 Mar 2010 11:39:47 +0000 (11:39 +0000)
committeracoul <acoul@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 22 Mar 2010 11:39:47 +0000 (11:39 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@20366 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/hostap-driver/Makefile

index f78d7877d91ba8a7596da3557e6a84e7a9a1aa10..0867672b8a53c52aa8f272d1ecdee0616e2a822e 100644 (file)
@@ -79,7 +79,7 @@ endef
 define KernelPackage/hostap-cs
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP driver for PCMCIA adaptors
-  DEPENDS:=@PCMCIA_SUPPORT kmod-hostap +kmod-pcmcia-core
+  DEPENDS:=@PCMCIA_SUPPORT +kmod-hostap +kmod-pcmcia-core
   KCONFIG:=CONFIG_HOSTAP_CS
   AUTOLOAD:=$(call AutoLoad,60,hostap_cs)
 endef
@@ -103,7 +103,7 @@ endef
 define KernelPackage/hostap-pci
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP driver for PCI adaptors
-  DEPENDS:= kmod-hostap
+  DEPENDS:=@@PCI_SUPPORT +kmod-hostap
   KCONFIG:=CONFIG_HOSTAP_PCI
   AUTOLOAD:=$(call AutoLoad,60,hostap_pci)
 endef
@@ -129,7 +129,7 @@ endef
 define KernelPackage/hostap-plx
 $(call KernelPackage/hostap/Default)
   TITLE:=Host AP driver for PLX9052 based PCI adaptors
-  DEPENDS:=@PCI_SUPPORT kmod-hostap
+  DEPENDS:=@PCI_SUPPORT +kmod-hostap
   KCONFIG:=CONFIG_HOSTAP_PLX
   AUTOLOAD:=$(call AutoLoad,60,hostap_plx)
 endef