[backfire] firewall: merge r28874
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 11:12:42 +0000 (11:12 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 9 Nov 2011 11:12:42 +0000 (11:12 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@28875 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/firewall/Makefile
package/firewall/files/firewall.config

index 14f31a4aee5e15f117e00a266c29e47a2c70e324..5feba5638439f6eb63904bd56754f60c6e123ee6 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=firewall
 
 PKG_VERSION:=2
-PKG_RELEASE:=34.6
+PKG_RELEASE:=34.7
 
 include $(INCLUDE_DIR)/package.mk
 
index d2b9c0e2612e694a2bdd03d123188eed08a26f18..d6a125d49ba9d85e2138a9b613fb068c49bdfd4f 100644 (file)
@@ -43,6 +43,18 @@ config rule
        option family           ipv4
        option target           ACCEPT
 
+# Allow DHCPv6 replies
+# see https://dev.openwrt.org/ticket/10381
+config rule
+       option src              wan
+       option proto            udp
+       option src_ip           fe80::/10
+       option src_port         547
+       option dest_ip          fe80::/10
+       option dest_port        546
+       option family           ipv6
+       option target           ACCEPT
+
 # Allow essential incoming IPv6 ICMP traffic
 config rule
        option src              wan