ar71xx: the squashfs-4k images are unreliable in some builds. add 4k, 8k padding...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Nov 2009 13:55:40 +0000 (13:55 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 24 Nov 2009 13:55:40 +0000 (13:55 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18526 3c298f89-4303-0410-b956-a3cf2f4a3e73

include/image.mk
target/linux/ar71xx/image/Makefile

index a722086a07df5d90e903d72cb86dab9507df9103..d75ca3c30f5cd69d6f4a6ec9161a667b988d12ca 100644 (file)
@@ -40,13 +40,17 @@ define add_jffs2_mark
        echo -ne '\xde\xad\xc0\xde' >> $(1)
 endef
 
-# pad to 64k and add jffs2 end-of-filesystem mark
-# do this twice to make sure that this works with 128k blocksize as well
+# pad to 4k, 8k, 64k, 128k and add jffs2 end-of-filesystem mark
 define prepare_generic_squashfs
-       dd if=$(1) of=$(KDIR)/tmpfile.1 bs=64k conv=sync
+       dd if=$(1) of=$(KDIR)/tmpfile.0 bs=4k conv=sync
+       $(call add_jffs2_mark,$(KDIR)/tmpfile.0)
+       dd if=$(KDIR)/tmpfile.0 of=$(KDIR)/tmpfile.1 bs=4k conv=sync
        $(call add_jffs2_mark,$(KDIR)/tmpfile.1)
-       dd of=$(1) if=$(KDIR)/tmpfile.1 bs=64k conv=sync
+       dd if=$(KDIR)/tmpfile.1 of=$(KDIR)/tmpfile.2 bs=64k conv=sync
+       $(call add_jffs2_mark,$(KDIR)/tmpfile.2)
+       dd if=$(KDIR)/tmpfile.2 of=$(1) bs=64k conv=sync
        $(call add_jffs2_mark,$(1))
+       rm -f $(KDIR)/tmpfile.*
 endef
 
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),y)
index 33937e402853e9477fcac22a0e7d8ff24ce2abfe..ed623de20c128438c475b61b75b93752a8d76361 100644 (file)
@@ -276,7 +276,7 @@ define Image/Build/Template/TPLINK4K
 endef
 
 define Image/Build/Template/TPLINK4K/squashfs
-       $(call Image/Build/Template/TPLINK,squashfs-4k,$(1),$(2),$(3))
+       $(call Image/Build/Template/TPLINK,squashfs,$(1),$(2),$(3))
 endef
 
 define Image/Build/Template/UBNT
@@ -296,7 +296,7 @@ define Image/Build/Template/UBNTXM
 endef
 
 define Image/Build/Template/UBNTXM/squashfs
-       $(call Image/Build/Template/UBNTXM,squashfs-4k,$(1),$(2),$(3),$(4),$(5))
+       $(call Image/Build/Template/UBNTXM,squashfs,$(1),$(2),$(3),$(4),$(5))
 endef
 
 define Image/Build/Template/UBNTXM/jffs2-64k
@@ -428,8 +428,6 @@ define Image/Build/Profile/Madwifi
 endef
 
 define Image/Build/squashfs
-       dd if=$(KDIR)/root.squashfs of=$(IMGNAME)-root.squashfs-4k bs=4k conv=sync
-       $(call add_jffs2_mark,$(IMGNAME)-root.squashfs-4k)
        $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
 endef