[ar71xx] create jffs2 images
authorjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 7 Jun 2009 20:07:32 +0000 (20:07 +0000)
committerjuhosg <juhosg@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 7 Jun 2009 20:07:32 +0000 (20:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16374 3c298f89-4303-0410-b956-a3cf2f4a3e73

target/linux/ar71xx/Makefile
target/linux/ar71xx/image/Makefile

index 8c44daf47e7d7ffada798d77522dc78c9fa013fc..5948e825c857a65626a294e959eef8cd3df04b28 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=ar71xx
 BOARDNAME:=Atheros AR71xx/AR913x
-FEATURES:=squashfs tgz
+FEATURES:=squashfs jffs2 tgz
 CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
 
 LINUX_VERSION:=2.6.28.10
index 02efef03b5db16d66bb26aeb63a32778b5168602..e1b36c209fbb77dbc986d6e83e6f346c6854906b 100644 (file)
@@ -119,7 +119,7 @@ define Image/Build/UBNT
                -B $(4) -v $(5).$(6).OpenWrt.$(REVISION) \
                -k $(KDIR)/vmlinux-$(2).bin.lzma \
                -r $(BIN_DIR)/openwrt-$(BOARD)-root.$(1) \
-               -o $(BIN_DIR)/openwrt-$(BOARD)-$(2)-$(1).bin
+               -o $(call imgname,$(1),$(2)).bin
 endef
 
 define Image/Build/Planex
@@ -174,6 +174,10 @@ define Image/Build/Template/Linksys8M/squashfs
        $(call Image/Build/Template/Linksys8M,squashfs,$(1),$(2),$(3))
 endef
 
+define Image/Build/Template/Linksys8M/jffs2-64k
+       $(call Image/Build/Template/Linksys8M,jffs2-64k,$(1),$(2),$(3))
+endef
+
 define Image/Build/Template/AP81
        $(call Image/Build/AP81,$(1),$(2),$(3),$(4))
 endef
@@ -190,6 +194,10 @@ define Image/Build/Template/AP83/squashfs
        $(call Image/Build/Template/AP83,squashfs,$(1),$(2))
 endef
 
+define Image/Build/Template/AP83/jffs2-64k
+       $(call Image/Build/Template/AP83,jffs2-64k,$(1),$(2))
+endef
+
 define Image/Build/Template/TPLINK
        $(call Image/Build/TPLINK,$(1),$(2),$(3),$(4))
 endef
@@ -206,6 +214,10 @@ define Image/Build/Template/UBNT/squashfs
        $(call Image/Build/Template/UBNT,squashfs,$(1),$(2),$(3),$(4),$(5))
 endef
 
+define Image/Build/Template/UBNT/jffs2-64k
+       $(call Image/Build/Template/UBNT,jffs2-64k,$(1),$(2),$(3),$(4),$(5))
+endef
+
 define Image/Build/Template/Planex
        $(call Image/Build/Planex,$(1),$(2),$(3))
 endef
@@ -214,6 +226,10 @@ define Image/Build/Template/Planex/squashfs
        $(call Image/Build/Template/Planex,squashfs,$(1),$(2))
 endef
 
+define Image/Build/Template/Planex/jffs2-64k
+       $(call Image/Build/Template/Planex,jffs2-64k,$(1),$(2))
+endef
+
 define Image/Build/Profile/AP83
        $(call Image/Build/Template/AP83/$(1),ap83,board=AP83)
 endef