[package] base-files: only try to execute watchdog if binary is present
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 Oct 2009 17:07:08 +0000 (17:07 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Tue, 20 Oct 2009 17:07:08 +0000 (17:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18102 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/base-files/Makefile
package/base-files/files/etc/init.d/watchdog

index 0fdbf113911707c587f25e2e1519e9b25e8d52b1..68cebfed731424bae7ba66a4a3ba3821dc372826 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=32
+PKG_RELEASE:=33
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 
index adb8f57c1393a291356237961a5bdb1a19b1fa5b..861a1f9eb04d412c09bf376e83503183aa9fe846 100755 (executable)
@@ -3,5 +3,6 @@
 
 START=97
 start() {
-        [ -c /dev/watchdog ] && watchdog -t 5 /dev/watchdog
+        [ -c /dev/watchdog ] && [ -x /sbin/watchdog ] && \
+               watchdog -t 5 /dev/watchdog
 }