more cleanup
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Feb 2007 23:38:02 +0000 (23:38 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 25 Feb 2007 23:38:02 +0000 (23:38 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6373 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/fuse/Makefile

index 5171b28851f3ce17adf9f85700efec5d5ec91264..d4641c115d1fe2cb905e05caf5c9d402f01c5fb9 100644 (file)
@@ -65,6 +65,18 @@ define Package/libfuse
        This package contains the FUSE shared library, needed by other programs.
 endef
 
+CONFIGURE_ARGS += \
+       --enable-shared \
+       --enable-static \
+       --disable-rpath \
+       --enable-kernel-module \
+       --enable-lib \
+       --enable-util \
+       --disable-example \
+       --disable-auto-modprobe \
+       --with-kernel="$(LINUX_DIR)" \
+       --disable-mtab
+
 define Build/Configure
        (cd $(PKG_BUILD_DIR); rm -f config.cache; \
                touch configure.in ; \
@@ -72,39 +84,8 @@ define Build/Configure
                touch Makefile.in ; \
                touch include/config.h.in ; \
                touch configure ; \
-               $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-               ./configure \
-                       --target=$(GNU_TARGET_NAME) \
-                       --host=$(GNU_TARGET_NAME) \
-                       --build=$(GNU_HOST_NAME) \
-                       --program-prefix="" \
-                       --program-suffix="" \
-                       --prefix=/usr \
-                       --exec-prefix=/usr \
-                       --bindir=/usr/bin \
-                       --datadir=/usr/share \
-                       --includedir=/usr/include \
-                       --infodir=/usr/share/info \
-                       --libdir=/usr/lib \
-                       --libexecdir=/usr/lib \
-                       --localstatedir=/var \
-                       --mandir=/usr/share/man \
-                       --sbindir=/usr/sbin \
-                       --sysconfdir=/etc \
-                       $(DISABLE_LARGEFILE) \
-                       $(DISABLE_NLS) \
-                       --enable-shared \
-                       --enable-static \
-                       --disable-rpath \
-                       --enable-kernel-module \
-                       --enable-lib \
-                       --enable-util \
-                       --disable-example \
-                       --disable-auto-modprobe \
-                       --with-kernel="$(LINUX_DIR)" \
-                       --disable-mtab \
-       );
+       )
+       $(call Build/Configure/Default)
 endef
 
 define Build/Compile