move several instances of DEFAULT:=y to profile preselections (easier for the image...
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Jan 2007 17:56:42 +0000 (17:56 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 14 Jan 2007 17:56:42 +0000 (17:56 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@6096 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/broadcom-diag/Makefile
package/broadcom-wl/Makefile
package/wlcompat/Makefile
target/linux/brcm-2.4/Makefile
target/linux/brcm-2.6/Makefile

index 9ab377a4f897a991775d67bb715f0510c710ba94..edc1026c272f36445ddab15ae82ff815b864bbec 100644 (file)
@@ -19,7 +19,6 @@ include $(INCLUDE_DIR)/package.mk
 define KernelPackage/diag
   SECTION:=kernel
   CATEGORY:=Kernel drivers
-  DEFAULT:=y
   DEPENDS:=@LINUX_2_4_BRCM||LINUX_2_6_BRCM
   TITLE:=Driver for router LEDs and Buttons
   VERSION:=$(PKG_RELEASE)+$(LINUX_VERSION)-$(BOARD)-$(LINUX_RELEASE)
index 769cfe8eabc025aa7fe149aab6858d466dd09983..93fc378979d9fbd0806494358ec1980aa19e6993 100644 (file)
@@ -57,7 +57,6 @@ endef
 define Package/wlc
   $(call Package/broadcom-wl/Default)
   TITLE:=wl driver setup utility
-  DEFAULT:=y
   DESCRIPTION:=\
        This package contains an utility for initializing the proprietary Broadcom \\\
        wl driver.
@@ -74,7 +73,6 @@ endef
 define Package/nas
   $(call Package/broadcom-wl/Default)
   DEPENDS+=+nvram
-  DEFAULT:=y
   TITLE:=Proprietary Broadcom WPA/WPA2 authenticator
   DESCRIPTION:=\
        This package contains the proprietary WPA/WPA2 authenticator (nas) for the \\\
index ceb5969d9220ee339dbd2ac061d3508104bb239b..aa34e61aae43c3c3264748b634d6553429ce1b6e 100644 (file)
@@ -29,7 +29,6 @@ endef
 
 define Package/kmod-wlcompat
   $(call Package/kmod-wlcompat/Default)
-  DEFAULT:=y
 endef
 
 define Package/kmod-wlcompat-debug
index 4e1267df352eafa32c8f438dbcc980eac52f0720..83741c1599a7ca5018c33e48f16061063132792f 100644 (file)
@@ -23,17 +23,17 @@ endef
 KERNEL:=2.4
 
 include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch nvram
+DEFAULT_PACKAGES += kmod-switch kmod-diag nvram
 
 define Profile/Broadcom
   NAME:=Generic, Broadcom WiFi (default)
-  PACKAGES:=kmod-brcm-wl 
+  PACKAGES:=kmod-brcm-wl wlc nas kmod-wlcompat
 endef
 $(eval $(call Profile,Broadcom))
 
 define Profile/BroadcomMimo
   NAME:=Generic, Broadcom WiFi (MIMO)
-  PACKAGES:=kmod-brcm-wl-mimo
+  PACKAGES:=kmod-brcm-wl-mimo wlc nas kmod-wlcompat
 endef
 $(eval $(call Profile,BroadcomMimo))
 
@@ -52,31 +52,31 @@ $(eval $(call Profile,None))
 
 define Profile/WRT54G3G
   NAME:=Linksys WRT54G3G
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-pcmcia-core kmod-pcmcia-serial kmod-nozomi comgt wlc nas kmod-wlcompat
 endef
 $(eval $(call Profile,WRT54G3G))
 
 define Profile/WL500G
   NAME:=ASUS WL-500g
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-lp
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-lp wlc nas kmod-wlcompat
 endef
 $(eval $(call Profile,WL500G))
 
 define Profile/WL500GD
   NAME:=ASUS WL-500g Deluxe
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-uhci kmod-usb2
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-uhci kmod-usb2 wlc nas kmod-wlcompat
 endef
 $(eval $(call Profile,WL500GD))
 
 define Profile/WL500GP
   NAME:=ASUS WL-500g Premium
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-usb2 wlc nas kmod-wlcompat
 endef
 $(eval $(call Profile,WL500GP))
 
 define Profile/WLHDD
   NAME:=WL-HDD
-  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx
+  PACKAGES:=kmod-brcm-wl kmod-usb-core kmod-usb-ohci kmod-ide-core kmod-ide-pdc202xx wlc nas kmod-wlcompat
 endef
 $(eval $(call Profile,WLHDD))
 
index 8e69332c2865707487bc0da070b3037c36d4dc65..7b57fd13194d13b2bc10a7b947339ab1d09bf91d 100644 (file)
@@ -21,7 +21,7 @@ define Target/Description
 endef
 
 include $(INCLUDE_DIR)/kernel-build.mk
-DEFAULT_PACKAGES += kmod-switch
+DEFAULT_PACKAGES += kmod-switch kmod-diag
 
 define Profile/Atheros
   NAME:=Atheros WiFi (default)