fix keynote compile
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 29 Dec 2007 19:19:22 +0000 (19:19 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 29 Dec 2007 19:19:22 +0000 (19:19 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@10030 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/keynote/Makefile

index 5b27257b4a74ddb3831210a5fea861f381f3d3af..56bbeb0e5849842765c73295e63c6cdb4832795a 100644 (file)
@@ -40,6 +40,8 @@ CONFIGURE_ARGS += \
 MAKE_FLAGS += \
        CFLAGS="$(TARGET_CFLAGS)"
 
+TARGET_CFLAGS += -Dbcopy=memmove -Dindex\(s,c\)=strchr\(s,c\)
+
 define Build/InstallDev
        mkdir -p $(1)/usr/include/keynote
        $(CP) $(PKG_BUILD_DIR)/{assertion,header,keynote,signature}.h $(1)/usr/include/keynote/