uboot-ifxmips: fix compile errors with the cs toolchain due to non-PIC code
authornbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 Nov 2009 21:25:31 +0000 (21:25 +0000)
committernbd <nbd@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Thu, 5 Nov 2009 21:25:31 +0000 (21:25 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@18321 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/uboot-ifxmips/patches/110-compile_fix.patch [new file with mode: 0644]

diff --git a/package/uboot-ifxmips/patches/110-compile_fix.patch b/package/uboot-ifxmips/patches/110-compile_fix.patch
new file mode 100644 (file)
index 0000000..34d0ac6
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/cpu/mips/Makefile
++++ b/cpu/mips/Makefile
+@@ -36,6 +36,9 @@ START        := $(addprefix $(obj),$(START))
+ all:  $(obj).depend $(START) $(LIB)
++start.o: start.S
++      $(CC) $(AFLAGS) -fPIC -c -o $@ $<
++
+ $(LIB):       $(OBJS)
+       $(AR) $(ARFLAGS) $@ $(OBJS)
+--- a/Makefile
++++ b/Makefile
+@@ -185,8 +185,8 @@ include $(TOPDIR)/config.mk
+ OBJS  = cpu/$(CPU)/start.o
+ OBJS_BOOTSTRAP  = cpu/$(CPU)/start_bootstrap.o
+-cpu/$(CPU)/start_bootstrap.S: cpu/$(CPU)/start.S
+-      ln -s start.S cpu/$(CPU)/start_bootstrap.S
++cpu/$(CPU)/start_bootstrap.o: cpu/$(CPU)/start.S
++      $(CC) $(AFLAGS) -fPIC -DCFG_BOOTSTRAP_CODE -c -o $@ $<
+ ifeq ($(CPU),i386)
+ OBJS += cpu/$(CPU)/start16.o