[backfire] merge r27163
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Jun 2011 19:31:30 +0000 (19:31 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sun, 12 Jun 2011 19:31:30 +0000 (19:31 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/branches/backfire@27164 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/6to4/Makefile
package/6to4/files/6to4.sh

index a6f3315a4ae656274ee16c572ee39a28627e750b..77082a4a046ca88b88e2f63be0b097db8c13d56e 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2010 OpenWrt.org
+# Copyright (C) 2010-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=6to4
-PKG_VERSION:=4
+PKG_VERSION:=5
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 9a85aa734c34f3b7ed583c641c91f5d5c3a19686..ab8afe90b89014b59a06b78348f21ef192769525 100755 (executable)
@@ -30,6 +30,7 @@ test_6to4_rfc1918()
 set_6to4_radvd_interface() {
        local cfgid="$1"
        local lanif="${2:-lan}"
+       local ifmtu="${3:-1280}"
        local ifsection=""
 
        find_ifsection() {
@@ -55,6 +56,7 @@ set_6to4_radvd_interface() {
        uci_set_state radvd "$ifsection" IgnoreIfMissing   1
        uci_set_state radvd "$ifsection" AdvSendAdvert     1
        uci_set_state radvd "$ifsection" MaxRtrAdvInterval 30
+       uci_set_state radvd "$ifsection" AdvLinkMTU        "$ifmtu"
 }
 
 set_6to4_radvd_prefix() {
@@ -203,7 +205,7 @@ setup_interface_6to4() {
                                        logger -t "$link" " * Advertising IPv6 subnet $subnet6 on ${adv_interface:-lan} ($adv_ifname)"
                                        ip -6 addr add $subnet6 dev $adv_ifname
 
-                                       set_6to4_radvd_interface "$sid" "$adv_interface"
+                                       set_6to4_radvd_interface "$sid" "$adv_interface" "$mtu"
                                        set_6to4_radvd_prefix    "$sid" "$adv_interface" \
                                                "$wancfg" "$(printf "0:0:0:%x::/64" $adv_subnet)"
 
@@ -252,9 +254,8 @@ stop_interface_6to4() {
                        done
                }
 
-               [ "$defaultroute" = "1" ] && {
-                       ip -6 route del 2000::/3 via ::192.88.99.1 dev $link metric 1
-               }
+               [ "$defaultroute" = "1" ] && \
+                       ip -6 route del 2000::/3 via ::192.88.99.1 dev $link
 
                ip addr del $local6 dev $link
                ip link set $link down