[package] madwifi: Disable compression capability on AR71XX and make it optional...
authoracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 1 Jul 2009 17:07:52 +0000 (17:07 +0000)
committeracinonyx <acinonyx@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Wed, 1 Jul 2009 17:07:52 +0000 (17:07 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@16642 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/madwifi/Config.in
package/madwifi/Makefile

index 6191ce2db4fe9c1366cffc54a8426db51e749154..23cc433f3d159c91faea8fd26dbba932610793f4 100644 (file)
@@ -5,6 +5,14 @@ config MADWIFI_DEBUG
        depends on DEVEL && PACKAGE_kmod-madwifi
        default n
 
+config MADWIFI_COMPRESSION
+       bool "Enable Atheros Super A/G Compression"
+       depends on PACKAGE_kmod-madwifi
+       depends !TARGET_ar71xx
+       default n
+       help
+         Enables Atheros Super A/G Hardware Compression Engine.
+
 choice
        prompt "Madwifi version"
        depends on PACKAGE_kmod-madwifi
index 93f695db952ce62ffdd2d74661102964706697dc..5e6273ccae294e0beaf64bfa64a1de81ae51547d 100644 (file)
@@ -46,7 +46,11 @@ PKG_BUILD_DEPENDS:=wprobe
 
 include $(INCLUDE_DIR)/package.mk
 
-COMPRESSION:=1
+ifdef CONFIG_MADWIFI_COMPRESSION
+  COMPRESSION:=1
+else
+  COMPRESSION:=0
+endif
 
 define Download/hal
   FILE:=$(HAL_FILE)