[package] add kmod-input-rb532, driver for the rb532 user button
authorflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Oct 2009 20:05:56 +0000 (20:05 +0000)
committerflorian <florian@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Mon, 5 Oct 2009 20:05:56 +0000 (20:05 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@17927 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/kernel/modules/other.mk

index 1b8e533cdc53f021b6714f2c4e7881b8c5ef846d..58b0561bc6bb4648ea3206c4fbc78e297f75d735 100644 (file)
@@ -724,6 +724,23 @@ endef
 
 $(eval $(call KernelPackage,input-joydev))
 
+define KernelPackage/input-rb532
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=RB532 button device support
+  DEPENDS:=+kmod-input-core @TARGET_rb532
+  KCONFIG:= \
+       CONFIG_INPUT_MISC=y \
+       CONFIG_INPUT_RB532_BUTTON
+  FILES:=$(LINUX_DIR)/drivers/input/misc/rb532_button.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,62,rb532_button)
+endef
+
+define KernelPackage/input-rb532/description
+  Kernel module for RB532 button
+endef
+
+$(eval $(call KernelPackage,input-rb532))
+
 
 define KernelPackage/mmc-atmelmci
   SUBMENU:=$(OTHER_MENU)