[package] iptables: update to v1.4.6, relocate patches - patch by Edgar Soldin
authorjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Jan 2010 22:28:32 +0000 (22:28 +0000)
committerjow <jow@3c298f89-4303-0410-b956-a3cf2f4a3e73>
Sat, 23 Jan 2010 22:28:32 +0000 (22:28 +0000)
git-svn-id: svn://svn.openwrt.org/openwrt/trunk@19302 3c298f89-4303-0410-b956-a3cf2f4a3e73

package/iptables/Makefile
package/iptables/patches/002-layer7_2.17.patch [moved from package/iptables/patches/1.4.4/002-layer7_2.17.patch with 100% similarity]
package/iptables/patches/005-imq.patch [moved from package/iptables/patches/1.4.4/005-imq.patch with 96% similarity]
package/iptables/patches/008-netfilter_include_linux_type_h.patch [moved from package/iptables/patches/1.4.4/008-netfilter_include_linux_type_h.patch with 100% similarity]
package/iptables/patches/009-table-alignment.patch [moved from package/iptables/patches/1.4.4/009-table-alignment.patch with 100% similarity]

index 60f4754ca9842c2738d03d5dee138250be59f282..be5b95b1492c5c2632a2c18174fd67b8b968f63e 100644 (file)
@@ -9,18 +9,16 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=iptables
-PKG_VERSION:=1.4.4
-PKG_RELEASE:=3
+PKG_VERSION:=1.4.6
+PKG_RELEASE:=1
 
-PKG_MD5SUM:=08cd9196881657ea0615d926334cb7e9
+PKG_MD5SUM:=c67cf30e281a924def6426be0973df56
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:=http://www.netfilter.org/projects/iptables/files \
        ftp://ftp.be.netfilter.org/pub/netfilter/iptables/ \
        ftp://ftp.de.netfilter.org/pub/netfilter/iptables/ \
        ftp://ftp.no.netfilter.org/pub/netfilter/iptables/
 
-PATCH_DIR:=./patches/$(PKG_VERSION)
-
 PKG_FIXUP = libtool
 
 include $(INCLUDE_DIR)/package.mk
@@ -336,7 +334,7 @@ endef
 
 define Package/libiptc/install
        $(INSTALL_DIR) $(1)/usr/lib
-       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libiptc.so* $(1)/usr/lib/
+       $(CP) $(PKG_INSTALL_DIR)/usr/lib/libip*tc.so* $(1)/usr/lib/
 endef
 
 define Package/libxtables/install
similarity index 96%
rename from package/iptables/patches/1.4.4/005-imq.patch
rename to package/iptables/patches/005-imq.patch
index fb5860a39b5aaad22f6685439e6cfc44201c3771..9e4d6277b5b091761ac5364e42142a0406ce9db6 100644 (file)
@@ -48,7 +48,7 @@
 +
 +      switch(c) {
 +      case '1':
-+              if (xtables_check_inverse(optarg, &invert, NULL, 0))
++              if (xtables_check_inverse(optarg, &invert, NULL, 0, argv))
 +                      xtables_error(PARAMETER_PROBLEM,
 +                                 "Unexpected `!' after --todev");
 +              mr->todev=atoi(optarg);
@@ -80,7 +80,7 @@
 +static struct xtables_target imq_target = {
 +      .name           = "IMQ",
 +      .version        = XTABLES_VERSION,
-+      .family         = AF_INET,
++      .family         = NFPROTO_IPV4,
 +      .size           = XT_ALIGN(sizeof(struct xt_imq_info)),
 +      .userspacesize  = XT_ALIGN(sizeof(struct xt_imq_info)),
 +      .help           = IMQ_help,
@@ -94,7 +94,7 @@
 +static struct xtables_target imq_target6 = {
 +      .name           = "IMQ",
 +      .version        = XTABLES_VERSION,
-+      .family         = AF_INET6,
++      .family         = NFPROTO_IPV6,
 +      .size           = XT_ALIGN(sizeof(struct xt_imq_info)),
 +      .userspacesize  = XT_ALIGN(sizeof(struct xt_imq_info)),
 +      .help           = IMQ_help,